GHSA-jmh9-6rjq-gjh9 Vulnerable embedded jQuery Version
An attacker can execute arbitrary JavaScript in the victim's browser via cross-site scripting in the embedded jQuery library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is GHSA-jmh9-6rjq-gjh9?
GHSA-jmh9-6rjq-gjh9 is a cross-site scripting vulnerability in pimcore/admin-ui-classic-bundle, published on 5 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Summary
PIMCore uses the JavaScript library jQuery in version 3.4.1. This version is vulnerable to cross-site-scripting (XSS).
Details
In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing elements from untrusted sources - even after sanitizing it to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.
Publish Date: 2020-04-29
Which versions are affected by GHSA-jmh9-6rjq-gjh9?
2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle.
| Package | Affected | Fixed in |
|---|---|---|
pimcore/admin-ui-classic-bundle Packagist | All versions | 1.4.3 |
pimcore/admin-ui-classic-bundle Packagist | All versions | 1.4.3 |
How do I fix GHSA-jmh9-6rjq-gjh9?
Upgrade pimcore/admin-ui-classic-bundle to 1.4.3 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is GHSA-jmh9-6rjq-gjh9 being exploited?
There is no known exploitation of GHSA-jmh9-6rjq-gjh9 in the wild and no public exploit code.