{"answers":{"affected":"2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle.","exploited":"There is no known exploitation of GHSA-jmh9-6rjq-gjh9 in the wild and no public exploit code.","fix":"Upgrade pimcore/admin-ui-classic-bundle to 1.4.3 or later.","what":"GHSA-jmh9-6rjq-gjh9 is a cross-site scripting vulnerability in pimcore/admin-ui-classic-bundle, published on 5 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-jmh9-6rjq-gjh9 and fix it if it is affected.\n\nWhat it is: GHSA-jmh9-6rjq-gjh9 is a cross-site scripting vulnerability in pimcore/admin-ui-classic-bundle, published on 5 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-jmh9-6rjq-gjh9 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.4.3\n- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-jmh9-6rjq-gjh9/ (Markdown: https://insights.sbomify.com/GHSA-jmh9-6rjq-gjh9/index.md)","id":"GHSA-jmh9-6rjq-gjh9","markdown":"https://insights.sbomify.com/GHSA-jmh9-6rjq-gjh9/index.md","name":"GHSA-jmh9-6rjq-gjh9","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript library","requires_auth":"none","summary":"An attacker can execute arbitrary JavaScript in the victim's browser via cross-site scripting in the embedded jQuery library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\nPIMCore uses the JavaScript library jQuery in version 3.4.1. This version is vulnerable to cross-site-scripting (XSS).\n\n### Details\nIn jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing elements from untrusted sources - even after sanitizing it to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.\n\nPublish Date: 2020-04-29\n\nURL:= https://security.snyk.io/package/npm/jquery/3.4.1","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Vulnerable embedded jQuery Version","id":"GHSA-jmh9-6rjq-gjh9","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.4.3"],"introduced":["0"],"last_affected":[],"package":"pimcore/admin-ui-classic-bundle","purl":null,"source":"GHSA-jmh9-6rjq-gjh9"},{"ecosystem":"Packagist","fixed":["1.4.3"],"introduced":["0"],"last_affected":[],"package":"pimcore/admin-ui-classic-bundle","purl":"pkg:composer/pimcore/admin-ui-classic-bundle","source":"GHSA-jmh9-6rjq-gjh9"}],"products":null,"published":"2024-06-05","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can execute arbitrary JavaScript in the victim's browser via cross-site scripting in the embedded jQuery library.","url":"https://insights.sbomify.com/GHSA-jmh9-6rjq-gjh9/"}