# GHSA-jmh9-6rjq-gjh9: Vulnerable embedded jQuery Version

> An attacker can execute arbitrary JavaScript in the victim's browser via cross-site scripting in the embedded jQuery library.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Jun 2024

## What is GHSA-jmh9-6rjq-gjh9?

GHSA-jmh9-6rjq-gjh9 is a cross-site scripting vulnerability in pimcore/admin-ui-classic-bundle, published on 5 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

### Summary
PIMCore uses the JavaScript library jQuery in version 3.4.1. This version is vulnerable to cross-site-scripting (XSS).

### Details
In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing elements from untrusted sources - even after sanitizing it to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

Publish Date: 2020-04-29

URL:= https://security.snyk.io/package/npm/jquery/3.4.1

## Which versions are affected by GHSA-jmh9-6rjq-gjh9?

2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.4.3 |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.4.3 |

## How do I fix GHSA-jmh9-6rjq-gjh9?

Upgrade pimcore/admin-ui-classic-bundle to 1.4.3 or later.

## Is GHSA-jmh9-6rjq-gjh9 being exploited?

There is no known exploitation of GHSA-jmh9-6rjq-gjh9 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-jmh9-6rjq-gjh9 and fix it if it is affected.

What it is: GHSA-jmh9-6rjq-gjh9 is a cross-site scripting vulnerability in pimcore/admin-ui-classic-bundle, published on 5 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-jmh9-6rjq-gjh9 in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.4.3
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-jmh9-6rjq-gjh9/ (Markdown: https://insights.sbomify.com/GHSA-jmh9-6rjq-gjh9/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-jmh9-6rjq-gjh9

---
From sbomify Insights: https://insights.sbomify.com/GHSA-jmh9-6rjq-gjh9/
Summaries are generated and may contain mistakes; the official description above is the record.
