{"answers":{"affected":"2 open source packages ship an affected version, including @cap-js/openapi.","exploited":"There is no known exploitation of GHSA-jpvj-wpmj-h7rv in the wild and no public exploit code.","fix":"Upgrade @cap-js/openapi to 1.4.2 or later.","what":"GHSA-jpvj-wpmj-h7rv is a vulnerability in @cap-js/openapi, published on 4 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-jpvj-wpmj-h7rv and fix it if it is affected.\n\nWhat it is: GHSA-jpvj-wpmj-h7rv is a vulnerability in @cap-js/openapi, published on 4 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-jpvj-wpmj-h7rv in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @cap-js/openapi (npm): affected from 1.4.1; fixed in 1.4.2\n- @cap-js/openapi (npm): affected from 1.4.1; fixed in 1.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-jpvj-wpmj-h7rv/ (Markdown: https://insights.sbomify.com/GHSA-jpvj-wpmj-h7rv/index.md)","id":"GHSA-jpvj-wpmj-h7rv","markdown":"https://insights.sbomify.com/GHSA-jpvj-wpmj-h7rv/index.md","name":"GHSA-jpvj-wpmj-h7rv","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"npm package","requires_auth":"none","summary":"A compromised npm package harvested credentials and self-propagated, requiring immediate upgrade and credential rotation for affected users.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nOn May 19, 2026, a compromised version of @cap-js/openapi@1.4.1 was published.\nThe malicious packages harvested credentials and attempted self-propagation.\nIf a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised.\n\n### Patches\n\nUpgrade to @cap-js/openapi \u003e= 1.4.2\nIf the compromised version was ever installed, rotate all affected credentials.\n\n### Workarounds\nNo workarounds.\n\n### References\n\n- [SAP Note 3747787](https://me.sap.com/notes/3747787)\n- [Developer FAQ](https://www.sap.com/documents/2026/05/8203a8b9-4d7f-0010-bca6-c68f7e60039b.html)","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Supply chain compromise via malicious @cap-js/openapi","id":"GHSA-jpvj-wpmj-h7rv","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.4.2"],"introduced":["1.4.1"],"last_affected":[],"package":"@cap-js/openapi","purl":null,"source":"GHSA-jpvj-wpmj-h7rv"},{"ecosystem":"npm","fixed":["1.4.2"],"introduced":["1.4.1"],"last_affected":[],"package":"@cap-js/openapi","purl":"pkg:npm/%40cap-js/openapi","source":"GHSA-jpvj-wpmj-h7rv"}],"products":null,"published":"2026-06-04","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A compromised npm package harvested credentials and self-propagated, requiring immediate upgrade and credential rotation for affected users.","url":"https://insights.sbomify.com/GHSA-jpvj-wpmj-h7rv/"}