# GHSA-jq9q-6p42-qpr7: Cross-site Scripting (XSS) in DemoBundle/ezdemo bundled VideoJS

> An XSS vulnerability in the bundled VideoJS Flash player allows attackers to execute scripts in the context of users viewing videos in the eZ Publish DemoBundle.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 May 2024

## What is GHSA-jq9q-6p42-qpr7?

GHSA-jq9q-6p42-qpr7 is a cross-site scripting vulnerability in ezsystems/ezdemo-ls-extension, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

his Security Advisory is about a vulnerability in VideoJS, which is bundled in DemoBundle and the ezdemo legacy extension. Older releases of VideoJS contain an XSS vulnerability in the Flash-based video player. This is bundled in DemoBundle, and in the Legacy "ezdemo" and "ezdemo-ls-extension" extensions. Among the branches still receiving security advisories, only eZ Publish Platform 5.4 and eZ Publish Legacy 5.4 are affected. However, it may be possible to make this software work in newer branches, so please check whether you have it installed even if you're using eZ Platform 1.x or 2.x.

Because DemoBundle / ezdemo are only intended for demo purposes, they are not supported software. For that reason, and given the old age of the software, and manpower issues during the Coronavirus crisis, we are taking the unusual step of simply removing the affected file. This resolves the vulnerability, but also breaks the video playback feature. It may be possible to make it work again by upgrading to a current version of VideoJS, but it is unlikely that we will do this, given the reasons already mentioned.

## Which versions are affected by GHSA-jq9q-6p42-qpr7?

2 open source packages ship an affected version, including ezsystems/ezdemo-ls-extension.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ezsystems/ezdemo-ls-extension` | Packagist | From 5.4.0 | 5.4.2.1 |
| `ezsystems/ezdemo-ls-extension` | Packagist | From 5.4.0 | 5.4.2.1 |

## How do I fix GHSA-jq9q-6p42-qpr7?

Upgrade ezsystems/ezdemo-ls-extension to 5.4.2.1 or later.

## Is GHSA-jq9q-6p42-qpr7 being exploited?

There is no known exploitation of GHSA-jq9q-6p42-qpr7 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-jq9q-6p42-qpr7 and fix it if it is affected.

What it is: GHSA-jq9q-6p42-qpr7 is a cross-site scripting vulnerability in ezsystems/ezdemo-ls-extension, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-jq9q-6p42-qpr7 in the wild and no public exploit code.

Affected packages and fixed versions:
- ezsystems/ezdemo-ls-extension (Packagist): affected from 5.4.0; fixed in 5.4.2.1
- ezsystems/ezdemo-ls-extension (Packagist): affected from 5.4.0; fixed in 5.4.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-jq9q-6p42-qpr7/ (Markdown: https://insights.sbomify.com/GHSA-jq9q-6p42-qpr7/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-jq9q-6p42-qpr7

---
From sbomify Insights: https://insights.sbomify.com/GHSA-jq9q-6p42-qpr7/
Summaries are generated and may contain mistakes; the official description above is the record.
