# GHSA-jqj4-r483-4gvr: Reflected cross-site scripting in default RouteNotFoundError view in Vaadin 10 and 11-13

> Attackers can execute malicious JavaScript in user browsers via crafted URLs due to missing output sanitization in the default RouteNotFoundError view.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Apr 2021

## What is GHSA-jqj4-r483-4gvr?

GHSA-jqj4-r483-4gvr is a cross-site scripting vulnerability in com.vaadin:vaadin-bom, published on 19 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Missing output sanitization in default `RouteNotFoundError` view in `com.vaadin:flow-server` versions 1.0.0 through 1.0.10 (Vaadin 10.0.0 through 10.0.13), and 1.1.0 through 1.4.2 (Vaadin 11.0.0 through 13.0.5) allows attacker to execute malicious JavaScript via crafted URL.

- https://vaadin.com/security/cve-2019-25027

## Which versions are affected by GHSA-jqj4-r483-4gvr?

4 open source packages ship an affected version, including com.vaadin:vaadin-bom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:vaadin-bom` | Maven | From 10.0.0 | 10.0.14 |
| `com.vaadin:vaadin-bom` | Maven | From 10.0.0 | 10.0.14 |
| `com.vaadin:vaadin-bom` | Maven | From 11.0.0 | 13.0.6 |
| `com.vaadin:vaadin-bom` | Maven | From 11.0.0 | 13.0.6 |

## How do I fix GHSA-jqj4-r483-4gvr?

Upgrade com.vaadin:vaadin-bom to a fixed version for your release line: 10.0.14 or 13.0.6.

## Is GHSA-jqj4-r483-4gvr being exploited?

There is no known exploitation of GHSA-jqj4-r483-4gvr in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-jqj4-r483-4gvr and fix it if it is affected.

What it is: GHSA-jqj4-r483-4gvr is a cross-site scripting vulnerability in com.vaadin:vaadin-bom, published on 19 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-jqj4-r483-4gvr in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:vaadin-bom (Maven): affected from 10.0.0; fixed in 10.0.14
- com.vaadin:vaadin-bom (Maven): affected from 10.0.0; fixed in 10.0.14
- com.vaadin:vaadin-bom (Maven): affected from 11.0.0; fixed in 13.0.6
- com.vaadin:vaadin-bom (Maven): affected from 11.0.0; fixed in 13.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-jqj4-r483-4gvr/ (Markdown: https://insights.sbomify.com/GHSA-jqj4-r483-4gvr/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-jqj4-r483-4gvr

---
From sbomify Insights: https://insights.sbomify.com/GHSA-jqj4-r483-4gvr/
Summaries are generated and may contain mistakes; the official description above is the record.
