{"answers":{"affected":"2 open source packages ship an affected version, including shopware/shopware.","exploited":"There is no known exploitation of GHSA-jqr7-5h7r-ch8p in the wild and no public exploit code.","fix":"Upgrade shopware/shopware to 5.3.7 or later.","what":"GHSA-jqr7-5h7r-ch8p is a cross-site scripting vulnerability in shopware/shopware, published on 21 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-jqr7-5h7r-ch8p and fix it if it is affected.\n\nWhat it is: GHSA-jqr7-5h7r-ch8p is a cross-site scripting vulnerability in shopware/shopware, published on 21 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-jqr7-5h7r-ch8p in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- shopware/shopware (Packagist): affected from 5.2.0; fixed in 5.3.7\n- shopware/shopware (Packagist): affected from 5.2.0; fixed in 5.3.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-jqr7-5h7r-ch8p/ (Markdown: https://insights.sbomify.com/GHSA-jqr7-5h7r-ch8p/index.md)","id":"GHSA-jqr7-5h7r-ch8p","markdown":"https://insights.sbomify.com/GHSA-jqr7-5h7r-ch8p/index.md","name":"GHSA-jqr7-5h7r-ch8p","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Shopware eCommerce platform","requires_auth":"none","summary":"Attackers can inject malicious scripts into the Shopware frontend, potentially compromising user sessions and data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A non-persistent Cross-Site Scripting (XSS) vulnerability has been identified in the Shopware eCommerce platform within the frontend. This vulnerability may allow an attacker to inject and execute malicious scripts in the context of a victim's web browser.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Shopware Non-Persistent XSS in the Frontend","id":"GHSA-jqr7-5h7r-ch8p","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["5.3.7"],"introduced":["5.2.0"],"last_affected":[],"package":"shopware/shopware","purl":null,"source":"GHSA-jqr7-5h7r-ch8p"},{"ecosystem":"Packagist","fixed":["5.3.7"],"introduced":["5.2.0"],"last_affected":[],"package":"shopware/shopware","purl":"pkg:composer/shopware/shopware","source":"GHSA-jqr7-5h7r-ch8p"}],"products":null,"published":"2024-05-21","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can inject malicious scripts into the Shopware frontend, potentially compromising user sessions and data.","url":"https://insights.sbomify.com/GHSA-jqr7-5h7r-ch8p/"}