GHSA-jrpw-8884-2747 eZ Platform Bundled jQuery affected by CVE-2019-11358

Not scored Published

An attacker can execute arbitrary JavaScript in the victim's browser via a cross-site scripting vulnerability in the bundled jQuery library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is GHSA-jrpw-8884-2747?

GHSA-jrpw-8884-2747 is a cross-site scripting vulnerability in ezsystems/ezplatform-admin-ui-assets, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

In eZ Platform 2.x, ezsystems/ezplatform-admin-ui-assets before v4.2.0 includes jQuery version 3.3.1. This version of jQuery is affected by the security vulnerability https://www.cvedetails.com/cve/CVE-2019-11358/ This is fixed in jQuery version 3.4. We recommend that you upgrade your ezsystems/ezplatform-admin-ui-assets to v4.2.0 using Composer. This release includes jQuery 3.4.1.

Which versions are affected by GHSA-jrpw-8884-2747?

2 open source packages ship an affected version, including ezsystems/ezplatform-admin-ui-assets.

PackageAffectedFixed in
ezsystems/ezplatform-admin-ui-assets PackagistFrom 4.0.04.2.0
ezsystems/ezplatform-admin-ui-assets PackagistFrom 4.0.04.2.0

How do I fix GHSA-jrpw-8884-2747?

Upgrade ezsystems/ezplatform-admin-ui-assets to 4.2.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is GHSA-jrpw-8884-2747 being exploited?

There is no known exploitation of GHSA-jrpw-8884-2747 in the wild and no public exploit code.

Sources

Is GHSA-jrpw-8884-2747 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free