{"answers":{"affected":"2 open source packages ship an affected version, including ezsystems/ezplatform-admin-ui-assets.","exploited":"There is no known exploitation of GHSA-jrpw-8884-2747 in the wild and no public exploit code.","fix":"Upgrade ezsystems/ezplatform-admin-ui-assets to 4.2.0 or later.","what":"GHSA-jrpw-8884-2747 is a cross-site scripting vulnerability in ezsystems/ezplatform-admin-ui-assets, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-jrpw-8884-2747 and fix it if it is affected.\n\nWhat it is: GHSA-jrpw-8884-2747 is a cross-site scripting vulnerability in ezsystems/ezplatform-admin-ui-assets, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-jrpw-8884-2747 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ezsystems/ezplatform-admin-ui-assets (Packagist): affected from 4.0.0; fixed in 4.2.0\n- ezsystems/ezplatform-admin-ui-assets (Packagist): affected from 4.0.0; fixed in 4.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-jrpw-8884-2747/ (Markdown: https://insights.sbomify.com/GHSA-jrpw-8884-2747/index.md)","id":"GHSA-jrpw-8884-2747","markdown":"https://insights.sbomify.com/GHSA-jrpw-8884-2747/index.md","name":"GHSA-jrpw-8884-2747","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"eZ Platform admin assets","requires_auth":"none","summary":"An attacker can execute arbitrary JavaScript in the victim's browser via a cross-site scripting vulnerability in the bundled jQuery library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"In eZ Platform 2.x, ezsystems/ezplatform-admin-ui-assets before v4.2.0 includes jQuery version 3.3.1. This version of jQuery is affected by the security vulnerability https://www.cvedetails.com/cve/CVE-2019-11358/\nThis is fixed in jQuery version 3.4. We recommend that you upgrade your ezsystems/ezplatform-admin-ui-assets to v4.2.0 using Composer. This release includes jQuery 3.4.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"eZ Platform Bundled jQuery affected by CVE-2019-11358","id":"GHSA-jrpw-8884-2747","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["4.2.0"],"introduced":["4.0.0"],"last_affected":[],"package":"ezsystems/ezplatform-admin-ui-assets","purl":null,"source":"GHSA-jrpw-8884-2747"},{"ecosystem":"Packagist","fixed":["4.2.0"],"introduced":["4.0.0"],"last_affected":[],"package":"ezsystems/ezplatform-admin-ui-assets","purl":"pkg:composer/ezsystems/ezplatform-admin-ui-assets","source":"GHSA-jrpw-8884-2747"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can execute arbitrary JavaScript in the victim's browser via a cross-site scripting vulnerability in the bundled jQuery library.","url":"https://insights.sbomify.com/GHSA-jrpw-8884-2747/"}