# GHSA-jrpw-8884-2747: eZ Platform Bundled jQuery affected by CVE-2019-11358

> An attacker can execute arbitrary JavaScript in the victim's browser via a cross-site scripting vulnerability in the bundled jQuery library.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 May 2024

## What is GHSA-jrpw-8884-2747?

GHSA-jrpw-8884-2747 is a cross-site scripting vulnerability in ezsystems/ezplatform-admin-ui-assets, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In eZ Platform 2.x, ezsystems/ezplatform-admin-ui-assets before v4.2.0 includes jQuery version 3.3.1. This version of jQuery is affected by the security vulnerability https://www.cvedetails.com/cve/CVE-2019-11358/
This is fixed in jQuery version 3.4. We recommend that you upgrade your ezsystems/ezplatform-admin-ui-assets to v4.2.0 using Composer. This release includes jQuery 3.4.1.

## Which versions are affected by GHSA-jrpw-8884-2747?

2 open source packages ship an affected version, including ezsystems/ezplatform-admin-ui-assets.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ezsystems/ezplatform-admin-ui-assets` | Packagist | From 4.0.0 | 4.2.0 |
| `ezsystems/ezplatform-admin-ui-assets` | Packagist | From 4.0.0 | 4.2.0 |

## How do I fix GHSA-jrpw-8884-2747?

Upgrade ezsystems/ezplatform-admin-ui-assets to 4.2.0 or later.

## Is GHSA-jrpw-8884-2747 being exploited?

There is no known exploitation of GHSA-jrpw-8884-2747 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-jrpw-8884-2747 and fix it if it is affected.

What it is: GHSA-jrpw-8884-2747 is a cross-site scripting vulnerability in ezsystems/ezplatform-admin-ui-assets, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-jrpw-8884-2747 in the wild and no public exploit code.

Affected packages and fixed versions:
- ezsystems/ezplatform-admin-ui-assets (Packagist): affected from 4.0.0; fixed in 4.2.0
- ezsystems/ezplatform-admin-ui-assets (Packagist): affected from 4.0.0; fixed in 4.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-jrpw-8884-2747/ (Markdown: https://insights.sbomify.com/GHSA-jrpw-8884-2747/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-jrpw-8884-2747

---
From sbomify Insights: https://insights.sbomify.com/GHSA-jrpw-8884-2747/
Summaries are generated and may contain mistakes; the official description above is the record.
