GHSA-jvg4-9rc2-wvcr Generation of fake documents via public GET-call
Attackers can generate fake documents via a public GET request, requiring an upgrade to the latest Shopware version.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-jvg4-9rc2-wvcr?
GHSA-jvg4-9rc2-wvcr is a vulnerability in shopware/platform, published on 10 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Impact
Generation of fake documents via public GET-call
Patches
We recommend to update to the current version 6.3.5.1. You can get the update to 6.3.5.1 regularly via the Auto-Updater or directly via the download overview.
https://www.shopware.com/en/download/#shopware-6
Workarounds
For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659
For more information
https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2021
Which versions are affected by GHSA-jvg4-9rc2-wvcr?
2 open source packages ship an affected version, including shopware/platform.
| Package | Affected | Fixed in |
|---|---|---|
shopware/platform Packagist | All versions | 6.3.5.1 |
shopware/platform Packagist | All versions | 6.3.5.1 |
How do I fix GHSA-jvg4-9rc2-wvcr?
Upgrade shopware/platform to 6.3.5.1 or later.
Is GHSA-jvg4-9rc2-wvcr being exploited?
There is no known exploitation of GHSA-jvg4-9rc2-wvcr in the wild and no public exploit code.