{"answers":{"affected":"2 open source packages ship an affected version, including shopware/platform.","exploited":"There is no known exploitation of GHSA-jvg4-9rc2-wvcr in the wild and no public exploit code.","fix":"Upgrade shopware/platform to 6.3.5.1 or later.","what":"GHSA-jvg4-9rc2-wvcr is a vulnerability in shopware/platform, published on 10 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-jvg4-9rc2-wvcr and fix it if it is affected.\n\nWhat it is: GHSA-jvg4-9rc2-wvcr is a vulnerability in shopware/platform, published on 10 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-jvg4-9rc2-wvcr in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- shopware/platform (Packagist): affected all versions; fixed in 6.3.5.1\n- shopware/platform (Packagist): affected all versions; fixed in 6.3.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-jvg4-9rc2-wvcr/ (Markdown: https://insights.sbomify.com/GHSA-jvg4-9rc2-wvcr/index.md)","id":"GHSA-jvg4-9rc2-wvcr","markdown":"https://insights.sbomify.com/GHSA-jvg4-9rc2-wvcr/index.md","name":"GHSA-jvg4-9rc2-wvcr","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Shopware e-commerce platform","requires_auth":"none","summary":"Attackers can generate fake documents via a public GET request, requiring an upgrade to the latest Shopware version.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nGeneration of fake documents via public GET-call\n\n### Patches\nWe recommend to update to the current version 6.3.5.1. You can get the update to 6.3.5.1 regularly via the Auto-Updater or directly via the download overview.\n\nhttps://www.shopware.com/en/download/#shopware-6\n\n### Workarounds\nFor older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.\n\nhttps://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659\n\n### For more information\nhttps://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2021","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Generation of fake documents via public GET-call","id":"GHSA-jvg4-9rc2-wvcr","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"business_logic","year":"2021"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["6.3.5.1"],"introduced":["0"],"last_affected":[],"package":"shopware/platform","purl":null,"source":"GHSA-jvg4-9rc2-wvcr"},{"ecosystem":"Packagist","fixed":["6.3.5.1"],"introduced":["0"],"last_affected":[],"package":"shopware/platform","purl":"pkg:composer/shopware/platform","source":"GHSA-jvg4-9rc2-wvcr"}],"products":null,"published":"2021-02-10","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can generate fake documents via a public GET request, requiring an upgrade to the latest Shopware version.","url":"https://insights.sbomify.com/GHSA-jvg4-9rc2-wvcr/"}