# GHSA-jvg4-9rc2-wvcr: Generation of fake documents via public GET-call

> Attackers can generate fake documents via a public GET request, requiring an upgrade to the latest Shopware version.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Feb 2021

## What is GHSA-jvg4-9rc2-wvcr?

GHSA-jvg4-9rc2-wvcr is a vulnerability in shopware/platform, published on 10 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Impact
Generation of fake documents via public GET-call

### Patches
We recommend to update to the current version 6.3.5.1. You can get the update to 6.3.5.1 regularly via the Auto-Updater or directly via the download overview.

https://www.shopware.com/en/download/#shopware-6

### Workarounds
For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659

### For more information
https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2021

## Which versions are affected by GHSA-jvg4-9rc2-wvcr?

2 open source packages ship an affected version, including shopware/platform.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/platform` | Packagist | All versions | 6.3.5.1 |
| `shopware/platform` | Packagist | All versions | 6.3.5.1 |

## How do I fix GHSA-jvg4-9rc2-wvcr?

Upgrade shopware/platform to 6.3.5.1 or later.

## Is GHSA-jvg4-9rc2-wvcr being exploited?

There is no known exploitation of GHSA-jvg4-9rc2-wvcr in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-jvg4-9rc2-wvcr and fix it if it is affected.

What it is: GHSA-jvg4-9rc2-wvcr is a vulnerability in shopware/platform, published on 10 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-jvg4-9rc2-wvcr in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/platform (Packagist): affected all versions; fixed in 6.3.5.1
- shopware/platform (Packagist): affected all versions; fixed in 6.3.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-jvg4-9rc2-wvcr/ (Markdown: https://insights.sbomify.com/GHSA-jvg4-9rc2-wvcr/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-jvg4-9rc2-wvcr

---
From sbomify Insights: https://insights.sbomify.com/GHSA-jvg4-9rc2-wvcr/
Summaries are generated and may contain mistakes; the official description above is the record.
