{"answers":{"affected":"2 open source packages ship an affected version, including silverstripe/admin.","exploited":"There is no known exploitation of GHSA-jxcx-3h54-qqxx in the wild and no public exploit code.","fix":"Upgrade silverstripe/admin to 1.13.6 or later.","what":"GHSA-jxcx-3h54-qqxx is a cross-site scripting vulnerability in silverstripe/admin, published on 23 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-jxcx-3h54-qqxx and fix it if it is affected.\n\nWhat it is: GHSA-jxcx-3h54-qqxx is a cross-site scripting vulnerability in silverstripe/admin, published on 23 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-jxcx-3h54-qqxx in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- silverstripe/admin (Packagist): affected from 1.0.0; fixed in 1.13.6\n- silverstripe/admin (Packagist): affected from 1.0.0; fixed in 1.13.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-jxcx-3h54-qqxx/ (Markdown: https://insights.sbomify.com/GHSA-jxcx-3h54-qqxx/index.md)","id":"GHSA-jxcx-3h54-qqxx","markdown":"https://insights.sbomify.com/GHSA-jxcx-3h54-qqxx/index.md","name":"GHSA-jxcx-3h54-qqxx","record":{"aliases":[],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"SilverStripe CMS","requires_auth":"low_privilege","summary":"Attackers can execute scripts in SilverStripe CMS 4 admin interfaces via inherited TinyMCE XSS flaws, potentially stealing data or hijacking accounts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"TinyMCE 4.x is vulnerable to several XSS vectors, which had been patched in later versions. Two of these have been identified as affecting silverstripe/admin.\n\nOnly Silverstripe CMS 4 is affected by these vulnerabilities. It's not possible to upgrade Silverstripe CMS 4 to use a more recent release of TinyMCE without introducing breaking changes. Instead, the security patches that shipped in later releases of TinyMCE have been backported to the TinyMCE version bundled in silverstripe/admin.\n\nSilverstripe CMS 5 is not affected by these vulnerabilities because it uses TinyMCE 6.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"SilverStripe CMS Cross-site Scripting vulnerabilities inherited from TinyMCE","id":"GHSA-jxcx-3h54-qqxx","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.13.6"],"introduced":["1.0.0"],"last_affected":[],"package":"silverstripe/admin","purl":null,"source":"GHSA-jxcx-3h54-qqxx"},{"ecosystem":"Packagist","fixed":["1.13.6"],"introduced":["1.0.0"],"last_affected":[],"package":"silverstripe/admin","purl":"pkg:composer/silverstripe/admin","source":"GHSA-jxcx-3h54-qqxx"}],"products":null,"published":"2023-08-23","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute scripts in SilverStripe CMS 4 admin interfaces via inherited TinyMCE XSS flaws, potentially stealing data or hijacking accounts.","url":"https://insights.sbomify.com/GHSA-jxcx-3h54-qqxx/"}