{"answers":{"affected":"3 open source packages ship an affected version, including github.com/ethereum/go-ethereum.","exploited":"There is no known exploitation of GHSA-m6gx-rhvj-fh52 in the wild and no public exploit code.","fix":"Upgrade github.com/ethereum/go-ethereum to 1.9.24 or later.","what":"GHSA-m6gx-rhvj-fh52 is a denial of service vulnerability in github.com/ethereum/go-ethereum, published on 29 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-m6gx-rhvj-fh52 and fix it if it is affected.\n\nWhat it is: GHSA-m6gx-rhvj-fh52 is a denial of service vulnerability in github.com/ethereum/go-ethereum, published on 29 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-m6gx-rhvj-fh52 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/ethereum/go-ethereum (Go): affected all versions; fixed in 1.9.24\n- github.com/ethereum/go-ethereum (Go): affected all versions; fixed in 1.9.24\n- github.com/ethereum/go-ethereum (Go): affected all versions; fixed in 1.9.24\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-m6gx-rhvj-fh52/ (Markdown: https://insights.sbomify.com/GHSA-m6gx-rhvj-fh52/index.md)","id":"GHSA-m6gx-rhvj-fh52","markdown":"https://insights.sbomify.com/GHSA-m6gx-rhvj-fh52/index.md","name":"GHSA-m6gx-rhvj-fh52","record":{"aliases":["GO-2022-0392"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ethereum client","requires_auth":"none","summary":"An attacker can crash Ethereum nodes by exploiting a Go runtime flaw, requiring operators to rebuild with patched Go versions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nVersions of Geth built with Go `\u003c1.15.5` or `\u003c1.14.12` are most likely affected by a critical DoS-related security vulnerability. The golang team has registered the underlying flaw as ‘CVE-2020-28362’.\n\nWe recommend all users to rebuild (ideally `v1.9.24`) with Go `1.15.5` or `1.14.12`, to avoid node crashes. Alternatively, if you are running binaries distributed via one of our official channels, we’re going to release `v1.9.24` ourselves built with Go `1.15.5`.\n\n### Patches\nThis is not an issue in go-ethereum, rebuilding an older version with Go `1.15.5` or `1.14.12` will suffice to address the vulnerability. \n\n### Workarounds\nRebuilding with Go `1.15.5` or `1.14.12` will suffice to address the vulnerability. \n\n### References\n- https://blog.ethereum.org/2020/11/12/geth_security_release/\n- https://groups.google.com/g/golang-announce/c/NpBGTTmKzpM\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in [go-ethereum](https://github.com/ethereum/go-ethereum)\n* Email us at [security@ethereum.org](mailto:security@ethereum.org)","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of service in go-ethereum due to CVE-2020-28362","id":"GHSA-m6gx-rhvj-fh52","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["1.9.24"],"introduced":["0"],"last_affected":[],"package":"github.com/ethereum/go-ethereum","purl":null,"source":"GHSA-m6gx-rhvj-fh52"},{"ecosystem":"Go","fixed":["1.9.24"],"introduced":["0"],"last_affected":[],"package":"github.com/ethereum/go-ethereum","purl":"pkg:golang/github.com/ethereum/go-ethereum","source":"GHSA-m6gx-rhvj-fh52"},{"ecosystem":"Go","fixed":["1.9.24"],"introduced":["0"],"last_affected":[],"package":"github.com/ethereum/go-ethereum","purl":"pkg:golang/github.com/ethereum/go-ethereum","source":"GO-2022-0392"}],"products":null,"published":"2021-06-29","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can crash Ethereum nodes by exploiting a Go runtime flaw, requiring operators to rebuild with patched Go versions.","url":"https://insights.sbomify.com/GHSA-m6gx-rhvj-fh52/"}