{"answers":{"affected":"3 open source packages ship an affected version, including github.com/foxcpp/maddy.","exploited":"There is no known exploitation of GHSA-m6m5-pp4g-fcc8 in the wild and no public exploit code.","fix":"Upgrade github.com/foxcpp/maddy to 0.5.1 or later.","what":"GHSA-m6m5-pp4g-fcc8 is a denial of service vulnerability in github.com/foxcpp/maddy, published on 6 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-m6m5-pp4g-fcc8 and fix it if it is affected.\n\nWhat it is: GHSA-m6m5-pp4g-fcc8 is a denial of service vulnerability in github.com/foxcpp/maddy, published on 6 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-m6m5-pp4g-fcc8 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/foxcpp/maddy (Go): affected all versions; fixed in 0.5.1\n- github.com/foxcpp/maddy (Go): affected all versions; fixed in 0.5.1\n- github.com/foxcpp/maddy (Go): affected all versions; fixed in 0.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-m6m5-pp4g-fcc8/ (Markdown: https://insights.sbomify.com/GHSA-m6m5-pp4g-fcc8/index.md)","id":"GHSA-m6m5-pp4g-fcc8","markdown":"https://insights.sbomify.com/GHSA-m6m5-pp4g-fcc8/index.md","name":"GHSA-m6m5-pp4g-fcc8","record":{"aliases":["GO-2022-0374"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Go mail server","requires_auth":"low_privilege","summary":"An attacker can cause unbounded memory usage and denial of service by triggering errors during S3 storage writes in the maddy mail server.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nAnyone using storage.blob.s3 introduced in 0.5.0 with storage.imapsql.\n```\nstorage.imapsql local_mailboxes {\n  ...\n  msg_store s3 {\n    ...\n  }\n}\n```\n\n### Patches\n\nThe relevant commit is pushed to master and will be included in the 0.5.1 release.\n\nNo special handling of the issue has been done due to the small amount of affected users.\n\n### Workarounds\n\nNone.\n\n### References\n\n* Original report: https://github.com/foxcpp/maddy/issues/395\n* Fix: https://github.com/foxcpp/maddy/commit/07c8495ee4394fabbf5aac4df8aebeafb2fb29d8","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"S3 storage write is not aborted on errors leading to unbounded memory usage","id":"GHSA-m6m5-pp4g-fcc8","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["0.5.1"],"introduced":["0"],"last_affected":[],"package":"github.com/foxcpp/maddy","purl":null,"source":"GHSA-m6m5-pp4g-fcc8"},{"ecosystem":"Go","fixed":["0.5.1"],"introduced":["0"],"last_affected":[],"package":"github.com/foxcpp/maddy","purl":"pkg:golang/github.com/foxcpp/maddy","source":"GHSA-m6m5-pp4g-fcc8"},{"ecosystem":"Go","fixed":["0.5.1"],"introduced":["0"],"last_affected":[],"package":"github.com/foxcpp/maddy","purl":"pkg:golang/github.com/foxcpp/maddy","source":"GO-2022-0374"}],"products":null,"published":"2021-10-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can cause unbounded memory usage and denial of service by triggering errors during S3 storage writes in the maddy mail server.","url":"https://insights.sbomify.com/GHSA-m6m5-pp4g-fcc8/"}