{"answers":{"affected":"4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable.","exploited":"There is no known exploitation of GHSA-m6w8-fq7v-ph4m in the wild and no public exploit code.","fix":"Upgrade @openzeppelin/contracts to 4.4.2 or later.","what":"GHSA-m6w8-fq7v-ph4m is a vulnerability in @openzeppelin/contracts, published on 13 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-m6w8-fq7v-ph4m and fix it if it is affected.\n\nWhat it is: GHSA-m6w8-fq7v-ph4m is a vulnerability in @openzeppelin/contracts, published on 13 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-m6w8-fq7v-ph4m in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @openzeppelin/contracts (npm): affected from 4.3.0; fixed in 4.4.2\n- @openzeppelin/contracts (npm): affected from 4.3.0; fixed in 4.4.2\n- @openzeppelin/contracts-upgradeable (npm): affected from 4.3.0; fixed in 4.4.2\n- @openzeppelin/contracts-upgradeable (npm): affected from 4.3.0; fixed in 4.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-m6w8-fq7v-ph4m/ (Markdown: https://insights.sbomify.com/GHSA-m6w8-fq7v-ph4m/index.md)","id":"GHSA-m6w8-fq7v-ph4m","markdown":"https://insights.sbomify.com/GHSA-m6w8-fq7v-ph4m/index.md","name":"GHSA-m6w8-fq7v-ph4m","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenZeppelin Governor","requires_auth":"low_privilege","summary":"Incorrect ABI encoding in GovernorCompatibilityBravo allows creating governance proposals with wrong arguments, potentially altering execution logic.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nThe `GovernorCompatibilityBravo` module may lead to the creation of governance proposals that execute function calls with incorrect arguments due to bad ABI encoding. This happens if the proposal is created using explicit function signatures, e.g. a proposal to invoke the function `foo(uint256)` is created as `propose([target], [0], [\"foo(uint256)\"], [\"0x00..01\"])`. If the function selector is provided as part of the encoded proposal data the issue is not present, e.g. the same proposal is created as `propose([target], [0], [\"0x2fbebd3800..01\"])`, where `2fbebd38` is the function selector.\n\nWe've assessed the instances of this contract found on chain, and did not find any occurrence of this bug in the past. Proposal creation through Tally or OpenZeppelin Defender is not affected. The core `Governor` contract on its own is not affected.\n\n### Patches\n\nA fix is included in version v4.4.2 of `@openzeppelin/contracts` and `@openzeppelin/contracts-upgradeable`.\n\n### Workarounds\n\nDo not create proposals using explicit function signatures. Instead, use the `propose` function without the `signatures` argument, and create the proposal using the fully ABI-encoded function call including the function selector in the `calldatas` argument as explained above.\n\n### References\n\nhttps://github.com/OpenZeppelin/openzeppelin-contracts/issues/3099\n\n### Credits\n\nThis issue was identified and reported by @GeraldHost.\n\n### For more information\n\nIf you have any questions, comments, or need assistance regarding this advisory, email us at security@openzeppelin.com.\n\nTo submit security reports please use [our bug bounty on Immunefi](https://immunefi.com/bounty/openzeppelin/).","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"GovernorCompatibilityBravo incorrect ABI encoding may lead to unexpected behavior","id":"GHSA-m6w8-fq7v-ph4m","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"business_logic","year":"2022"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["4.4.2"],"introduced":["4.3.0"],"last_affected":[],"package":"@openzeppelin/contracts","purl":null,"source":"GHSA-m6w8-fq7v-ph4m"},{"ecosystem":"npm","fixed":["4.4.2"],"introduced":["4.3.0"],"last_affected":[],"package":"@openzeppelin/contracts","purl":"pkg:npm/%40openzeppelin/contracts","source":"GHSA-m6w8-fq7v-ph4m"},{"ecosystem":"npm","fixed":["4.4.2"],"introduced":["4.3.0"],"last_affected":[],"package":"@openzeppelin/contracts-upgradeable","purl":null,"source":"GHSA-m6w8-fq7v-ph4m"},{"ecosystem":"npm","fixed":["4.4.2"],"introduced":["4.3.0"],"last_affected":[],"package":"@openzeppelin/contracts-upgradeable","purl":"pkg:npm/%40openzeppelin/contracts-upgradeable","source":"GHSA-m6w8-fq7v-ph4m"}],"products":null,"published":"2022-01-13","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Incorrect ABI encoding in GovernorCompatibilityBravo allows creating governance proposals with wrong arguments, potentially altering execution logic.","url":"https://insights.sbomify.com/GHSA-m6w8-fq7v-ph4m/"}