{"answers":{"affected":"2 open source packages ship an affected version, including eslint-config-airbnb-standard.","exploited":"There is no known exploitation of GHSA-m852-866j-69j8 in the wild and no public exploit code.","fix":"Upgrade eslint-config-airbnb-standard to 2.1.0 or later.","what":"GHSA-m852-866j-69j8 is a vulnerability in eslint-config-airbnb-standard, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-m852-866j-69j8 and fix it if it is affected.\n\nWhat it is: GHSA-m852-866j-69j8 is a vulnerability in eslint-config-airbnb-standard, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-m852-866j-69j8 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- eslint-config-airbnb-standard (npm): affected from 2.0.0; fixed in 2.1.0\n- eslint-config-airbnb-standard (npm): affected from 2.0.0; fixed in 2.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-m852-866j-69j8/ (Markdown: https://insights.sbomify.com/GHSA-m852-866j-69j8/index.md)","id":"GHSA-m852-866j-69j8","markdown":"https://insights.sbomify.com/GHSA-m852-866j-69j8/index.md","name":"GHSA-m852-866j-69j8","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"npm linting config","requires_auth":"none","summary":"A malicious npm package exfiltrates user credentials from .npmrc files, requiring immediate token revocation and package replacement.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Version 2.0.0 of `eslint-config-airbnb-standard` was published with a bundled version of `eslint-scope` that  was found to contain malicious code. This code would read the users `.npmrc` file and send it's contents to a remote server.\n\n## Recommendation\n\nThe best course of action if you found this package installed in your environment is to revoke all your npm tokens and use a different version of the module. You can find instructions on how to do that here. https://docs.npmjs.com/getting-started/working_with_tokens#how-to-revoke-tokens","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Malicious Package in eslint-config-airbnb-standard","id":"GHSA-m852-866j-69j8","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.1.0"],"introduced":["2.0.0"],"last_affected":[],"package":"eslint-config-airbnb-standard","purl":null,"source":"GHSA-m852-866j-69j8"},{"ecosystem":"npm","fixed":["2.1.0"],"introduced":["2.0.0"],"last_affected":[],"package":"eslint-config-airbnb-standard","purl":"pkg:npm/eslint-config-airbnb-standard","source":"GHSA-m852-866j-69j8"}],"products":null,"published":"2020-09-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A malicious npm package exfiltrates user credentials from .npmrc files, requiring immediate token revocation and package replacement.","url":"https://insights.sbomify.com/GHSA-m852-866j-69j8/"}