GHSA-m9p2-fxp5-v3fp Diesel: Command injection in Diesel's implementation of `COPY FROM`/`COPY TO`

Not scored Published

Attackers can inject options into PostgreSQL COPY commands via unescaped quotes in Diesel library inputs, potentially modifying data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is GHSA-m9p2-fxp5-v3fp?

GHSA-m9p2-fxp5-v3fp is a command injection vulnerability in diesel, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Diesel allows users to configure various options for PostgreSQL's COPY FROM and COPY TO statements. These configurations are partially provided as strings or characters.

Diesel did not check if any these user-provided options contain a quote character ', which can lead to the injection of additional options in the current COPY FROM/COPY TO statement.

This vulnerability affects any user of COPY FROM/COPY TO that passes user-provided input to any of the affected functions. It can result in modifications of options in the current statement, but it is not possible inject additional statements.

Mitigation

The preferred mitigation to the outlined problem is to update to Diesel version 2.3.8 or newer, which includes fixes for the problem.

Resolution

Diesel now correctly escapes any quotes contained in the provided arguments.

Which versions are affected by GHSA-m9p2-fxp5-v3fp?

3 open source packages ship an affected version, including diesel.

PackageAffectedFixed in
diesel crates.ioAll versions2.3.8
diesel crates.ioAll versions2.3.8
diesel crates.ioFrom 0.0.0-02.3.8

How do I fix GHSA-m9p2-fxp5-v3fp?

Upgrade diesel to 2.3.8 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is GHSA-m9p2-fxp5-v3fp being exploited?

There is no known exploitation of GHSA-m9p2-fxp5-v3fp in the wild and no public exploit code.

Sources

Also known as RUSTSEC-2026-0136.

Is GHSA-m9p2-fxp5-v3fp in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free