{"answers":{"affected":"3 open source packages ship an affected version, including diesel.","exploited":"There is no known exploitation of GHSA-m9p2-fxp5-v3fp in the wild and no public exploit code.","fix":"Upgrade diesel to 2.3.8 or later.","what":"GHSA-m9p2-fxp5-v3fp is a command injection vulnerability in diesel, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-m9p2-fxp5-v3fp and fix it if it is affected.\n\nWhat it is: GHSA-m9p2-fxp5-v3fp is a command injection vulnerability in diesel, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-m9p2-fxp5-v3fp in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- diesel (crates.io): affected all versions; fixed in 2.3.8\n- diesel (crates.io): affected all versions; fixed in 2.3.8\n- diesel (crates.io): affected from 0.0.0-0; fixed in 2.3.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-m9p2-fxp5-v3fp/ (Markdown: https://insights.sbomify.com/GHSA-m9p2-fxp5-v3fp/index.md)","id":"GHSA-m9p2-fxp5-v3fp","markdown":"https://insights.sbomify.com/GHSA-m9p2-fxp5-v3fp/index.md","name":"GHSA-m9p2-fxp5-v3fp","record":{"aliases":["RUSTSEC-2026-0136"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust database library","requires_auth":"low_privilege","summary":"Attackers can inject options into PostgreSQL COPY commands via unescaped quotes in Diesel library inputs, potentially modifying data.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Diesel allows users to configure various options for PostgreSQL's `COPY FROM` and `COPY TO` statements. These configurations are partially provided as strings or characters. \n\nDiesel did not check if any these user-provided options contain a quote character `'`, which can lead to the injection of additional options in the current `COPY FROM`/`COPY TO` statement. \n\nThis vulnerability affects any user of `COPY FROM`/`COPY TO` that passes user-provided input to any of the affected functions. It can result in modifications of options in the current statement, but it is not possible inject additional statements.\n\n## Mitigation\n\nThe preferred mitigation to the outlined problem is to update to Diesel version 2.3.8 or newer, which includes fixes for the problem.\n\n## Resolution\n\nDiesel now correctly escapes any quotes contained in the provided arguments.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Diesel: Command injection in Diesel's implementation of `COPY FROM`/`COPY TO`","id":"GHSA-m9p2-fxp5-v3fp","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["2.3.8"],"introduced":["0"],"last_affected":[],"package":"diesel","purl":null,"source":"GHSA-m9p2-fxp5-v3fp"},{"ecosystem":"crates.io","fixed":["2.3.8"],"introduced":["0"],"last_affected":[],"package":"diesel","purl":"pkg:cargo/diesel","source":"GHSA-m9p2-fxp5-v3fp"},{"ecosystem":"crates.io","fixed":["2.3.8"],"introduced":["0.0.0-0"],"last_affected":[],"package":"diesel","purl":"pkg:cargo/diesel","source":"RUSTSEC-2026-0136"}],"products":null,"published":"2026-04-24","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can inject options into PostgreSQL COPY commands via unescaped quotes in Diesel library inputs, potentially modifying data.","url":"https://insights.sbomify.com/GHSA-m9p2-fxp5-v3fp/"}