{"answers":{"affected":"3 open source packages ship an affected version, including libdav1d-sys.","exploited":"There is no known exploitation of GHSA-mc39-h54g-pvw6 in the wild and no public exploit code.","fix":"Upgrade libdav1d-sys to 0.7.0 or later.","what":"GHSA-mc39-h54g-pvw6 is a vulnerability in libdav1d-sys, published on 19 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-mc39-h54g-pvw6 and fix it if it is affected.\n\nWhat it is: GHSA-mc39-h54g-pvw6 is a vulnerability in libdav1d-sys, published on 19 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-mc39-h54g-pvw6 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libdav1d-sys (crates.io): affected all versions; fixed in 0.7.0\n- libdav1d-sys (crates.io): affected all versions; fixed in 0.7.0\n- libdav1d-sys (crates.io): affected from 0.0.0-0; fixed in 0.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-mc39-h54g-pvw6/ (Markdown: https://insights.sbomify.com/GHSA-mc39-h54g-pvw6/index.md)","id":"GHSA-mc39-h54g-pvw6","markdown":"https://insights.sbomify.com/GHSA-mc39-h54g-pvw6/index.md","name":"GHSA-mc39-h54g-pvw6","record":{"aliases":["RUSTSEC-2024-0016"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust AV1 decoder binding","requires_auth":"none","summary":"An integer overflow in the dav1d AV1 decoder can lead to memory corruption when processing large frames, requiring an upgrade to libdav1d-sys.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"An integer overflow in dav1d AV1 decoder that can occur when decoding videos with large frame size. This can lead to memory corruption within the AV1 decoder. We recommend upgrading to version 0.7.0 of libdav1d-sys, which includes dav1d 1.4.0.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"libdav1d-sys affected by dav1d AV1 decoder integer overflow","id":"GHSA-mc39-h54g-pvw6","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"integer_overflow","year":"2024"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.7.0"],"introduced":["0"],"last_affected":[],"package":"libdav1d-sys","purl":null,"source":"GHSA-mc39-h54g-pvw6"},{"ecosystem":"crates.io","fixed":["0.7.0"],"introduced":["0"],"last_affected":[],"package":"libdav1d-sys","purl":"pkg:cargo/libdav1d-sys","source":"GHSA-mc39-h54g-pvw6"},{"ecosystem":"crates.io","fixed":["0.7.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"libdav1d-sys","purl":"pkg:cargo/libdav1d-sys","source":"RUSTSEC-2024-0016"}],"products":null,"published":"2024-02-19","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An integer overflow in the dav1d AV1 decoder can lead to memory corruption when processing large frames, requiring an upgrade to libdav1d-sys.","url":"https://insights.sbomify.com/GHSA-mc39-h54g-pvw6/"}