# GHSA-mc39-h54g-pvw6: libdav1d-sys affected by dav1d AV1 decoder integer overflow

> An integer overflow in the dav1d AV1 decoder can lead to memory corruption when processing large frames, requiring an upgrade to libdav1d-sys.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Feb 2024
- **Also known as:** RUSTSEC-2024-0016

## What is GHSA-mc39-h54g-pvw6?

GHSA-mc39-h54g-pvw6 is a vulnerability in libdav1d-sys, published on 19 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An integer overflow in dav1d AV1 decoder that can occur when decoding videos with large frame size. This can lead to memory corruption within the AV1 decoder. We recommend upgrading to version 0.7.0 of libdav1d-sys, which includes dav1d 1.4.0.

## Which versions are affected by GHSA-mc39-h54g-pvw6?

3 open source packages ship an affected version, including libdav1d-sys.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libdav1d-sys` | crates.io | All versions | 0.7.0 |
| `libdav1d-sys` | crates.io | All versions | 0.7.0 |
| `libdav1d-sys` | crates.io | From 0.0.0-0 | 0.7.0 |

## How do I fix GHSA-mc39-h54g-pvw6?

Upgrade libdav1d-sys to 0.7.0 or later.

## Is GHSA-mc39-h54g-pvw6 being exploited?

There is no known exploitation of GHSA-mc39-h54g-pvw6 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-mc39-h54g-pvw6 and fix it if it is affected.

What it is: GHSA-mc39-h54g-pvw6 is a vulnerability in libdav1d-sys, published on 19 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-mc39-h54g-pvw6 in the wild and no public exploit code.

Affected packages and fixed versions:
- libdav1d-sys (crates.io): affected all versions; fixed in 0.7.0
- libdav1d-sys (crates.io): affected all versions; fixed in 0.7.0
- libdav1d-sys (crates.io): affected from 0.0.0-0; fixed in 0.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-mc39-h54g-pvw6/ (Markdown: https://insights.sbomify.com/GHSA-mc39-h54g-pvw6/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-mc39-h54g-pvw6

---
From sbomify Insights: https://insights.sbomify.com/GHSA-mc39-h54g-pvw6/
Summaries are generated and may contain mistakes; the official description above is the record.
