{"answers":{"affected":"2 open source packages ship an affected version, including devalue.","exploited":"There is no known exploitation of GHSA-mcm9-63f2-9j32 in the wild and no public exploit code.","fix":"Upgrade devalue to 5.9.3 or later.","what":"GHSA-mcm9-63f2-9j32 is a denial of service vulnerability in devalue, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-mcm9-63f2-9j32 and fix it if it is affected.\n\nWhat it is: GHSA-mcm9-63f2-9j32 is a denial of service vulnerability in devalue, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-mcm9-63f2-9j32 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- devalue (npm): affected all versions; fixed in 5.9.3\n- devalue (npm): affected all versions; fixed in 5.9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-mcm9-63f2-9j32/ (Markdown: https://insights.sbomify.com/GHSA-mcm9-63f2-9j32/index.md)","id":"GHSA-mcm9-63f2-9j32","markdown":"https://insights.sbomify.com/GHSA-mcm9-63f2-9j32/index.md","name":"GHSA-mcm9-63f2-9j32","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript serialization library","requires_auth":"none","summary":"Attackers can cause denial of service by sending crafted data that expands quadratically during serialization in the devalue library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Under very constrained circumstances, data that was `parse`d and then passed to `uneval` could turn a small payload into a very large serialized string.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"devalue: Repeated primitive strings cause quadratic expansion in uneval","id":"GHSA-mcm9-63f2-9j32","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["5.9.3"],"introduced":["0"],"last_affected":[],"package":"devalue","purl":null,"source":"GHSA-mcm9-63f2-9j32"},{"ecosystem":"npm","fixed":["5.9.3"],"introduced":["0"],"last_affected":[],"package":"devalue","purl":"pkg:npm/devalue","source":"GHSA-mcm9-63f2-9j32"}],"products":null,"published":"2026-10-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service by sending crafted data that expands quadratically during serialization in the devalue library.","url":"https://insights.sbomify.com/GHSA-mcm9-63f2-9j32/"}