# GHSA-mcmr-49x3-4jqm: ckb type_id script resume may randomly fail

> Incorrect handling of cycle limits in CKB type_id scripts causes random verification failures, potentially disrupting blockchain operations.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Nov 2022

## What is GHSA-mcmr-49x3-4jqm?

GHSA-mcmr-49x3-4jqm is a denial of service vulnerability in ckb, published on 2 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Impact
https://github.com/nervosnetwork/ckb/blob/v0.101.2/script/src/verify.rs#L871-L879
TypeIdSystemScript resume handle is not correct when max_cycles is not enough, `ScriptError::ExceededMaximumCycles` will be raised directly ranther than suspend as expect, and also because script_group execution order is random, so this will happen randomly.

## Which versions are affected by GHSA-mcmr-49x3-4jqm?

2 open source packages ship an affected version, including ckb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ckb` | crates.io | From 0.100.0 | 0.102.0 |
| `ckb` | crates.io | From 0.100.0 | 0.102.0 |

## How do I fix GHSA-mcmr-49x3-4jqm?

Upgrade ckb to 0.102.0 or later.

## Is GHSA-mcmr-49x3-4jqm being exploited?

There is no known exploitation of GHSA-mcmr-49x3-4jqm in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-mcmr-49x3-4jqm and fix it if it is affected.

What it is: GHSA-mcmr-49x3-4jqm is a denial of service vulnerability in ckb, published on 2 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-mcmr-49x3-4jqm in the wild and no public exploit code.

Affected packages and fixed versions:
- ckb (crates.io): affected from 0.100.0; fixed in 0.102.0
- ckb (crates.io): affected from 0.100.0; fixed in 0.102.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-mcmr-49x3-4jqm/ (Markdown: https://insights.sbomify.com/GHSA-mcmr-49x3-4jqm/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-mcmr-49x3-4jqm

---
From sbomify Insights: https://insights.sbomify.com/GHSA-mcmr-49x3-4jqm/
Summaries are generated and may contain mistakes; the official description above is the record.
