GHSA-mf4f-j588-5xm8 Apache Log4j Remote Code Execution

Not scored Published

Attackers can execute arbitrary code remotely by controlling log messages in applications using vulnerable Log4j2 versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is GHSA-mf4f-j588-5xm8?

GHSA-mf4f-j588-5xm8 is a code injection vulnerability in org.opencastproject:opencast-common, published on 14 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Impact

Opencast uses an Apache Log4j2 version which, combined with older JDK versions, can be used for remote code execution attacks which have been found to be actively exploited.

Apache Log4j2 <=2.14.1 JNDI features is not sufficiently protected. An attacker who can control log messages or log message parameters can execute arbitrary code when message lookup substitution is enabled.

Who is affected

  • Opencast before 9.10 or 10.6 are affected
    • Log4j version: all 2.x versions before 2.15.0 are affected

Patches

The issue has been fixed in Opencast 9.10 and 10.6.

Workarounds

The vulnerability can be mitigated by setting system property log4j2.formatMsgNoLookups to true.

References

For more information

If you have any questions or comments about this advisory:

Note about dependencies

This issue affects many Java applications. Please also verify these are not vulnerable.

Which versions are affected by GHSA-mf4f-j588-5xm8?

4 open source packages ship an affected version, including org.opencastproject:opencast-common.

PackageAffectedFixed in
org.opencastproject:opencast-common MavenAll versions9.10
org.opencastproject:opencast-common MavenAll versions9.10
org.opencastproject:opencast-common MavenFrom 10.010.6
org.opencastproject:opencast-common MavenFrom 10.010.6

How do I fix GHSA-mf4f-j588-5xm8?

Upgrade org.opencastproject:opencast-common to a fixed version for your release line: 9.10 or 10.6.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is GHSA-mf4f-j588-5xm8 being exploited?

There is no known exploitation of GHSA-mf4f-j588-5xm8 in the wild and no public exploit code.

Sources

Is GHSA-mf4f-j588-5xm8 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free