{"answers":{"affected":"4 open source packages ship an affected version, including org.opencastproject:opencast-common.","exploited":"There is no known exploitation of GHSA-mf4f-j588-5xm8 in the wild and no public exploit code.","fix":"Upgrade org.opencastproject:opencast-common to a fixed version for your release line: 9.10 or 10.6.","what":"GHSA-mf4f-j588-5xm8 is a code injection vulnerability in org.opencastproject:opencast-common, published on 14 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-mf4f-j588-5xm8 and fix it if it is affected.\n\nWhat it is: GHSA-mf4f-j588-5xm8 is a code injection vulnerability in org.opencastproject:opencast-common, published on 14 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-mf4f-j588-5xm8 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.opencastproject:opencast-common (Maven): affected all versions; fixed in 9.10\n- org.opencastproject:opencast-common (Maven): affected all versions; fixed in 9.10\n- org.opencastproject:opencast-common (Maven): affected from 10.0; fixed in 10.6\n- org.opencastproject:opencast-common (Maven): affected from 10.0; fixed in 10.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-mf4f-j588-5xm8/ (Markdown: https://insights.sbomify.com/GHSA-mf4f-j588-5xm8/index.md)","id":"GHSA-mf4f-j588-5xm8","markdown":"https://insights.sbomify.com/GHSA-mf4f-j588-5xm8/index.md","name":"GHSA-mf4f-j588-5xm8","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java logging library","requires_auth":"none","summary":"Attackers can execute arbitrary code remotely by controlling log messages in applications using vulnerable Log4j2 versions.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nOpencast uses an Apache Log4j2 version which, combined with older JDK versions, can be used for remote code execution attacks which have been found to be actively exploited.\n\nApache Log4j2 \u003c=2.14.1 JNDI features is not sufficiently protected. An attacker who can control log messages or log message parameters can execute arbitrary code when message lookup substitution is enabled.\n\n### Who is affected\n\n- Opencast before 9.10 or 10.6 are affected\n    - Log4j version: all 2.x versions before 2.15.0 are affected\n\n### Patches\n\nThe issue has been fixed in Opencast 9.10 and 10.6.\n\n### Workarounds\n\nThe vulnerability can be mitigated by setting system property `log4j2.formatMsgNoLookups` to `true`.\n\n### References\n\n- [Opencast pull request mitigating the vulnerability](https://github.com/opencast/opencast/pull/3253)\n- [CVE-2021-44228 Detail](https://nvd.nist.gov/vuln/detail/CVE-2021-44228)\n- [Analysis and Remediation Guidance to the Log4j Zero-Day RCE (CVE-2021-44228) Vulnerability](https://www.veracode.com/blog/security-news/urgent-analysis-and-remediation-guidance-log4j-zero-day-rce-cve-2021-44228)\n- [VE-2021-44228 – Log4j 2 Vulnerability Analysis](https://www.randori.com/blog/cve-2021-44228/)\n\n### For more information\n\nIf you have any questions or comments about this advisory:\n* Open an issue in [our issue tracker](https://github.com/opencast/opencast/issues)\n* Email us at [security@opencast.org](mailto:security@opencast.org)\n\n### Note about dependencies\n\nThis issue affects many Java applications. Please also verify these are not vulnerable.","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Apache Log4j Remote Code Execution","id":"GHSA-mf4f-j588-5xm8","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["9.10"],"introduced":["0"],"last_affected":[],"package":"org.opencastproject:opencast-common","purl":null,"source":"GHSA-mf4f-j588-5xm8"},{"ecosystem":"Maven","fixed":["9.10"],"introduced":["0"],"last_affected":[],"package":"org.opencastproject:opencast-common","purl":"pkg:maven/org.opencastproject/opencast-common","source":"GHSA-mf4f-j588-5xm8"},{"ecosystem":"Maven","fixed":["10.6"],"introduced":["10.0"],"last_affected":[],"package":"org.opencastproject:opencast-common","purl":null,"source":"GHSA-mf4f-j588-5xm8"},{"ecosystem":"Maven","fixed":["10.6"],"introduced":["10.0"],"last_affected":[],"package":"org.opencastproject:opencast-common","purl":"pkg:maven/org.opencastproject/opencast-common","source":"GHSA-mf4f-j588-5xm8"}],"products":null,"published":"2021-12-14","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary code remotely by controlling log messages in applications using vulnerable Log4j2 versions.","url":"https://insights.sbomify.com/GHSA-mf4f-j588-5xm8/"}