{"answers":{"affected":"2 open source packages ship an affected version, including zendframework/zendframework.","exploited":"There is no known exploitation of GHSA-mg7h-9qfx-4r83 in the wild and no public exploit code.","fix":"Upgrade zendframework/zendframework to 2.0.5 or later.","what":"GHSA-mg7h-9qfx-4r83 is a vulnerability in zendframework/zendframework, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-mg7h-9qfx-4r83 and fix it if it is affected.\n\nWhat it is: GHSA-mg7h-9qfx-4r83 is a vulnerability in zendframework/zendframework, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-mg7h-9qfx-4r83 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zendframework/zendframework (Packagist): affected from 2.0.0; fixed in 2.0.5\n- zendframework/zendframework (Packagist): affected from 2.0.0; fixed in 2.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-mg7h-9qfx-4r83/ (Markdown: https://insights.sbomify.com/GHSA-mg7h-9qfx-4r83/index.md)","id":"GHSA-mg7h-9qfx-4r83","markdown":"https://insights.sbomify.com/GHSA-mg7h-9qfx-4r83/index.md","name":"GHSA-mg7h-9qfx-4r83","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP web framework","requires_auth":"none","summary":"Attackers can spoof IP addresses or host names via HTTP headers in Zend Framework, potentially bypassing security controls or leaking information.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"`Zend\\Session\\Validator\\RemoteAddr` and `Zend\\View\\Helper\\ServerUrl` were found to be improperly parsing HTTP headers for proxy information, which could potentially allow an attacker to spoof a proxied IP or host name.\n\nIn `Zend\\Session\\Validator\\RemoteAddr`, if the client is behind a proxy server, the detection of the proxy URL was incorrect, and could lead to invalid results on subsequent lookups.\n\nIn `Zend\\View\\Helper\\ServerUrl`, if the server lives behind a proxy, the helper would always generate a URL based on the proxy host, regardless of whether or not this was desired; additionally, it did not take into account the proxy port or protocol, if provided.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"ZendFramework Potential Proxy Injection Vulnerabilities","id":"GHSA-mg7h-9qfx-4r83","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"other","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.0.5"],"introduced":["2.0.0"],"last_affected":[],"package":"zendframework/zendframework","purl":null,"source":"GHSA-mg7h-9qfx-4r83"},{"ecosystem":"Packagist","fixed":["2.0.5"],"introduced":["2.0.0"],"last_affected":[],"package":"zendframework/zendframework","purl":"pkg:composer/zendframework/zendframework","source":"GHSA-mg7h-9qfx-4r83"}],"products":null,"published":"2024-06-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can spoof IP addresses or host names via HTTP headers in Zend Framework, potentially bypassing security controls or leaking information.","url":"https://insights.sbomify.com/GHSA-mg7h-9qfx-4r83/"}