{"answers":{"affected":"2 open source packages ship an affected version, including pterodactyl/panel.","exploited":"There is no known exploitation of GHSA-mgr9-6c2j-jxrq in the wild and no public exploit code.","fix":"Upgrade pterodactyl/panel to 1.12.0 or later.","what":"GHSA-mgr9-6c2j-jxrq is a cross-site scripting vulnerability in pterodactyl/panel, published on 30 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-mgr9-6c2j-jxrq and fix it if it is affected.\n\nWhat it is: GHSA-mgr9-6c2j-jxrq is a cross-site scripting vulnerability in pterodactyl/panel, published on 30 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-mgr9-6c2j-jxrq in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pterodactyl/panel (Packagist): affected all versions; fixed in 1.12.0\n- pterodactyl/panel (Packagist): affected all versions; fixed in 1.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-mgr9-6c2j-jxrq/ (Markdown: https://insights.sbomify.com/GHSA-mgr9-6c2j-jxrq/index.md)","id":"GHSA-mgr9-6c2j-jxrq","markdown":"https://insights.sbomify.com/GHSA-mgr9-6c2j-jxrq/index.md","name":"GHSA-mgr9-6c2j-jxrq","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Pterodactyl panel","requires_auth":"high_privilege","summary":"Administrators can trigger reflected XSS by pasting malicious scripts into the database host field, requiring self-interaction to exploit.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"\u003e [!NOTE]\n\u003e Message from the Pterodactyl team:\n\u003e\n\u003e The Pterodactyl team has evaluated this as a minor security issue but does not consider it something that should be assigned a CVE, nor does it require active patching by vulnerable systems.\n\u003e\n\u003e This issue is entirely self-inflicted and requires an administrative user paste an _obviously_ incorrect value into a database host field, submit it, and run into the XSS when the error message is rendered. However, we have determined that this fix is good security hygiene and may prevent issues in other areas not yet discovered.\n\n### Summary\nWhen an administrative user creates a new database host they are prompted to provide a `Host` value which is expected to be a domain or IP address. When an invalid value is encountered and passed back to `gethostaddr` and/or directly to the MySQL connection tooling, an error is returned. This error is then passed back along to the front-end, but was not properly sanitized when rendered.\n\nTherefore it is possible for an admin to _knowingly_ paste a malicious payload such as `\u003cscript\u003eprompt(document.domain)\u003c/script\u003e` into the `Host` field and XSS themselves.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Pterodactyl has a Reflected XSS vulnerability in “Create New Database Host”","id":"GHSA-mgr9-6c2j-jxrq","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.12.0"],"introduced":["0"],"last_affected":[],"package":"pterodactyl/panel","purl":null,"source":"GHSA-mgr9-6c2j-jxrq"},{"ecosystem":"Packagist","fixed":["1.12.0"],"introduced":["0"],"last_affected":[],"package":"pterodactyl/panel","purl":"pkg:composer/pterodactyl/panel","source":"GHSA-mgr9-6c2j-jxrq"}],"products":null,"published":"2025-12-30","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Administrators can trigger reflected XSS by pasting malicious scripts into the database host field, requiring self-interaction to exploit.","url":"https://insights.sbomify.com/GHSA-mgr9-6c2j-jxrq/"}