GHSA-mgv2-57vj-99xc Low severity vulnerability that affects eye.js

Not scored Published
Exploited in the wild
Not known
Fix
Available

What is GHSA-mgv2-57vj-99xc?

GHSA-mgv2-57vj-99xc is a vulnerability in eye.js, published on 7 Oct 2019.

Official description

Test breaking

Impact

In v1.2.0, tests are broken: all tests are always succeeding. If tests are looking for security vulnerabilities, these were compromised.

Patches

Users should upgrade to v1.2.1

Workarounds

Users who don't use eye.js for looking for vulnerabilities are safe. Upgrading will just fix some bugs.

For more information

If you have any questions or comments about this advisory:

Which versions are affected by GHSA-mgv2-57vj-99xc?

2 open source packages ship an affected version, including eye.js.

PackageAffectedFixed in
eye.js npmFrom 1.2.01.2.1
eye.js npmFrom 1.2.01.2.1

How do I fix GHSA-mgv2-57vj-99xc?

Upgrade eye.js to 1.2.1 or later.

Is GHSA-mgv2-57vj-99xc being exploited?

There is no known exploitation of GHSA-mgv2-57vj-99xc in the wild and no public exploit code.

Sources

Is GHSA-mgv2-57vj-99xc in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free