{"answers":{"affected":"2 open source packages ship an affected version, including eye.js.","exploited":"There is no known exploitation of GHSA-mgv2-57vj-99xc in the wild and no public exploit code.","fix":"Upgrade eye.js to 1.2.1 or later.","what":"GHSA-mgv2-57vj-99xc is a vulnerability in eye.js, published on 7 Oct 2019."},"fix_prompt":"Check this codebase for GHSA-mgv2-57vj-99xc and fix it if it is affected.\n\nWhat it is: GHSA-mgv2-57vj-99xc is a vulnerability in eye.js, published on 7 Oct 2019. \nExploitation: There is no known exploitation of GHSA-mgv2-57vj-99xc in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- eye.js (npm): affected from 1.2.0; fixed in 1.2.1\n- eye.js (npm): affected from 1.2.0; fixed in 1.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-mgv2-57vj-99xc/ (Markdown: https://insights.sbomify.com/GHSA-mgv2-57vj-99xc/index.md)","id":"GHSA-mgv2-57vj-99xc","markdown":"https://insights.sbomify.com/GHSA-mgv2-57vj-99xc/index.md","name":"GHSA-mgv2-57vj-99xc","record":{"aliases":[],"analysis":null,"analysis_generated_by":null,"assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Test breaking\n\n### Impact\nIn v1.2.0, tests are broken: all tests are always succeeding. If tests are looking for security vulnerabilities, these were compromised.\n\n### Patches\nUsers should upgrade to `v1.2.1`\n\n### Workarounds\nUsers who don't use eye.js for looking for vulnerabilities are safe. Upgrading will just fix some bugs.\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in [EyeJS](https://github.com/arguiot/EyeJS)\n* Email us at [arguiot@gmail.com](mailto:arguiot@gmail.com)","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Low severity vulnerability that affects eye.js","id":"GHSA-mgv2-57vj-99xc","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.2.1"],"introduced":["1.2.0"],"last_affected":[],"package":"eye.js","purl":null,"source":"GHSA-mgv2-57vj-99xc"},{"ecosystem":"npm","fixed":["1.2.1"],"introduced":["1.2.0"],"last_affected":[],"package":"eye.js","purl":"pkg:npm/eye.js","source":"GHSA-mgv2-57vj-99xc"}],"products":null,"published":"2019-10-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":null,"url":"https://insights.sbomify.com/GHSA-mgv2-57vj-99xc/"}