{"answers":{"affected":"2 open source packages ship an affected version, including sqlite3.","exploited":"There is no known exploitation of GHSA-mgvv-5mxp-xq67 in the wild and no public exploit code.","fix":"Upgrade sqlite3 to 1.5.1 or later.","what":"GHSA-mgvv-5mxp-xq67 is a vulnerability in sqlite3, published on 3 Oct 2022."},"fix_prompt":"Check this codebase for GHSA-mgvv-5mxp-xq67 and fix it if it is affected.\n\nWhat it is: GHSA-mgvv-5mxp-xq67 is a vulnerability in sqlite3, published on 3 Oct 2022. \nExploitation: There is no known exploitation of GHSA-mgvv-5mxp-xq67 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sqlite3 (RubyGems): affected from 1.5.0; fixed in 1.5.1\n- sqlite3 (RubyGems): affected from 1.5.0; fixed in 1.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-mgvv-5mxp-xq67/ (Markdown: https://insights.sbomify.com/GHSA-mgvv-5mxp-xq67/index.md)","id":"GHSA-mgvv-5mxp-xq67","markdown":"https://insights.sbomify.com/GHSA-mgvv-5mxp-xq67/index.md","name":"GHSA-mgvv-5mxp-xq67","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"unknown","non_default_config":false,"product_category":"Ruby SQLite3 gem","requires_auth":"high_privilege","summary":"An integer overflow in the FTS3 extension of the packaged libsqlite allows code execution if an attacker has full SQL access and can create a large corrupt database.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\n\nThe rubygem sqlite3 v1.5.1 upgrades the packaged version of libsqlite from v3.39.3 to [v3.39.4](https://sqlite.org/releaselog/3_39_4.html).\n\nlibsqlite v3.39.4 addresses a vulnerability described as follows in the release notification:\n\n\u003e Version 3.39.4 is a minimal patch against the prior release that addresses issues found since the\n\u003e prior release. In particular, a potential vulnerability in the FTS3 extension has been fixed, so\n\u003e this should be considered a security update.\n\u003e\n\u003e In order to exploit the vulnerability, an attacker must have full SQL access and must be able to\n\u003e construct a corrupt database with over 2GB of FTS3 content. The problem arises from a 32-bit\n\u003e signed integer overflow.\n\nThis vulnerability has not been assigned a CVE and does not have a severity declared.\n\nPlease note that this advisory only applies to the sqlite3 gem v1.5.0, and only if the packaged libsqlite is being used. If you've overridden defaults at installation time to use system libraries instead of packaged libraries, you should instead pay attention to your distro's libsqlite release announcements.\n\n### Mitigation\n\nUpgrade to the rubygem sqlite3 v1.5.1 or later.\n\nUsers who are unable to upgrade the sqlite3 gem may also choose a more complicated mitigation: compile and link sqlite3 against external libsqlite \u003e= 3.39.4 which will also address these same issues.\n\n### References\n\n- Upstream release notes: https://sqlite.org/releaselog/3_39_4.html\n- Instructions for compiling against system libraries: https://github.com/sparklemotion/sqlite3-ruby","ecosystems":["RubyGems"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"SQLite3 addresses vulnerability in packaged version of libsqlite","id":"GHSA-mgvv-5mxp-xq67","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"integer_overflow","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"RubyGems","fixed":["1.5.1"],"introduced":["1.5.0"],"last_affected":[],"package":"sqlite3","purl":null,"source":"GHSA-mgvv-5mxp-xq67"},{"ecosystem":"RubyGems","fixed":["1.5.1"],"introduced":["1.5.0"],"last_affected":[],"package":"sqlite3","purl":"pkg:gem/sqlite3","source":"GHSA-mgvv-5mxp-xq67"}],"products":null,"published":"2022-10-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An integer overflow in the FTS3 extension of the packaged libsqlite allows code execution if an attacker has full SQL access and can create a large corrupt database.","url":"https://insights.sbomify.com/GHSA-mgvv-5mxp-xq67/"}