GHSA-mh4h-27gq-cxwj Drupal core Access bypass
Drupal core allows unauthorized access to media items when the advanced UI is enabled, requiring an upgrade or configuration change.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-mh4h-27gq-cxwj?
GHSA-mh4h-27gq-cxwj is a missing authorization vulnerability in drupal/core, published on 15 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Media Library module has a security vulnerability whereby it doesn't sufficiently restrict access to media items in certain configurations.
Solution: If you are using Drupal 8.7.x, you should upgrade to Drupal 8.7.11. If you are using Drupal 8.8.x, you should upgrade to Drupal 8.8.1. Versions of Drupal 8 prior to 8.7.x are end-of-life and do not receive security coverage.
Alternatively, you may mitigate this vulnerability by unchecking the "Enable advanced UI" checkbox on /admin/config/media/media-library. (This mitigation is not available in 8.7.x.)
Which versions are affected by GHSA-mh4h-27gq-cxwj?
4 open source packages ship an affected version, including drupal/core.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 8.0.0 | 8.7.11 |
drupal/core Packagist | From 8.0.0 | 8.7.11 |
drupal/core Packagist | From 8.8.0 | 8.8.1 |
drupal/core Packagist | From 8.8.0 | 8.8.1 |
How do I fix GHSA-mh4h-27gq-cxwj?
Upgrade drupal/core to a fixed version for your release line: 8.7.11 or 8.8.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is GHSA-mh4h-27gq-cxwj being exploited?
There is no known exploitation of GHSA-mh4h-27gq-cxwj in the wild and no public exploit code.