{"answers":{"affected":"4 open source packages ship an affected version, including drupal/core.","exploited":"There is no known exploitation of GHSA-mh4h-27gq-cxwj in the wild and no public exploit code.","fix":"Upgrade drupal/core to a fixed version for your release line: 8.7.11 or 8.8.1.","what":"GHSA-mh4h-27gq-cxwj is a missing authorization vulnerability in drupal/core, published on 15 May 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-mh4h-27gq-cxwj and fix it if it is affected.\n\nWhat it is: GHSA-mh4h-27gq-cxwj is a missing authorization vulnerability in drupal/core, published on 15 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-mh4h-27gq-cxwj in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/core (Packagist): affected from 8.0.0; fixed in 8.7.11\n- drupal/core (Packagist): affected from 8.0.0; fixed in 8.7.11\n- drupal/core (Packagist): affected from 8.8.0; fixed in 8.8.1\n- drupal/core (Packagist): affected from 8.8.0; fixed in 8.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-mh4h-27gq-cxwj/ (Markdown: https://insights.sbomify.com/GHSA-mh4h-27gq-cxwj/index.md)","id":"GHSA-mh4h-27gq-cxwj","markdown":"https://insights.sbomify.com/GHSA-mh4h-27gq-cxwj/index.md","name":"GHSA-mh4h-27gq-cxwj","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Drupal core","requires_auth":"low_privilege","summary":"Drupal core allows unauthorized access to media items when the advanced UI is enabled, requiring an upgrade or configuration change.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The Media Library module has a security vulnerability whereby it doesn't sufficiently restrict access to media items in certain configurations.\n\nSolution:\nIf you are using Drupal 8.7.x, you should upgrade to Drupal 8.7.11.\nIf you are using Drupal 8.8.x, you should upgrade to Drupal 8.8.1.\nVersions of Drupal 8 prior to 8.7.x are end-of-life and do not receive security coverage.\n\nAlternatively, you may mitigate this vulnerability by unchecking the \"Enable advanced UI\" checkbox on `/admin/config/media/media-library`. (This mitigation is not available in 8.7.x.)","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Drupal core Access bypass","id":"GHSA-mh4h-27gq-cxwj","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["8.7.11"],"introduced":["8.0.0"],"last_affected":[],"package":"drupal/core","purl":null,"source":"GHSA-mh4h-27gq-cxwj"},{"ecosystem":"Packagist","fixed":["8.7.11"],"introduced":["8.0.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"GHSA-mh4h-27gq-cxwj"},{"ecosystem":"Packagist","fixed":["8.8.1"],"introduced":["8.8.0"],"last_affected":[],"package":"drupal/core","purl":null,"source":"GHSA-mh4h-27gq-cxwj"},{"ecosystem":"Packagist","fixed":["8.8.1"],"introduced":["8.8.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"GHSA-mh4h-27gq-cxwj"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Drupal core allows unauthorized access to media items when the advanced UI is enabled, requiring an upgrade or configuration change.","url":"https://insights.sbomify.com/GHSA-mh4h-27gq-cxwj/"}