{"answers":{"affected":"4 open source packages ship an affected version, including event-stream and flatmap-stream.","exploited":"There is no known exploitation of GHSA-mh6f-8j2x-4483 in the wild and no public exploit code.","fix":"Upgrade event-stream to 4.0.0 or later.","what":"GHSA-mh6f-8j2x-4483 is a vulnerability in event-stream, published on 26 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-mh6f-8j2x-4483 and fix it if it is affected.\n\nWhat it is: GHSA-mh6f-8j2x-4483 is a vulnerability in event-stream, published on 26 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-mh6f-8j2x-4483 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- event-stream (npm): affected from 3.3.6; fixed in 4.0.0\n- event-stream (npm): affected from 3.3.6; fixed in 4.0.0\n- flatmap-stream (npm): affected all versions; no fix listed\n- flatmap-stream (npm): affected all versions; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-mh6f-8j2x-4483/ (Markdown: https://insights.sbomify.com/GHSA-mh6f-8j2x-4483/index.md)","id":"GHSA-mh6f-8j2x-4483","markdown":"https://insights.sbomify.com/GHSA-mh6f-8j2x-4483/index.md","name":"GHSA-mh6f-8j2x-4483","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"npm package","requires_auth":"none","summary":"A malicious dependency in the event-stream npm package allows attackers to execute arbitrary code on systems using the affected library.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The NPM package `flatmap-stream` is considered malicious.  A malicious actor added this package as a dependency to the NPM `event-stream` package in version `3.3.6`.  Users of `event-stream` are encouraged to downgrade to the last non-malicious version, `3.3.4`, or upgrade to the latest  4.x version. \n\nUsers of `flatmap-stream` are encouraged to remove the dependency entirely.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Critical severity vulnerability that affects event-stream and flatmap-stream","id":"GHSA-mh6f-8j2x-4483","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2018"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["4.0.0"],"introduced":["3.3.6"],"last_affected":[],"package":"event-stream","purl":null,"source":"GHSA-mh6f-8j2x-4483"},{"ecosystem":"npm","fixed":["4.0.0"],"introduced":["3.3.6"],"last_affected":[],"package":"event-stream","purl":"pkg:npm/event-stream","source":"GHSA-mh6f-8j2x-4483"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":[],"package":"flatmap-stream","purl":null,"source":"GHSA-mh6f-8j2x-4483"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":[],"package":"flatmap-stream","purl":"pkg:npm/flatmap-stream","source":"GHSA-mh6f-8j2x-4483"}],"products":null,"published":"2018-11-26","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A malicious dependency in the event-stream npm package allows attackers to execute arbitrary code on systems using the affected library.","url":"https://insights.sbomify.com/GHSA-mh6f-8j2x-4483/"}