{"answers":{"affected":"2 open source packages ship an affected version, including zendframework/zendframework1.","exploited":"There is no known exploitation of GHSA-mhpx-3rv8-wrjm in the wild and no public exploit code.","fix":"Upgrade zendframework/zendframework1 to 1.12.4 or later.","what":"GHSA-mhpx-3rv8-wrjm is a vulnerability in zendframework/zendframework1, published on 7 Jun 2024. It can be exploited over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-mhpx-3rv8-wrjm and fix it if it is affected.\n\nWhat it is: GHSA-mhpx-3rv8-wrjm is a vulnerability in zendframework/zendframework1, published on 7 Jun 2024. It can be exploited over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-mhpx-3rv8-wrjm in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zendframework/zendframework1 (Packagist): affected from 1.12.0; fixed in 1.12.4\n- zendframework/zendframework1 (Packagist): affected from 1.12.0; fixed in 1.12.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-mhpx-3rv8-wrjm/ (Markdown: https://insights.sbomify.com/GHSA-mhpx-3rv8-wrjm/index.md)","id":"GHSA-mhpx-3rv8-wrjm","markdown":"https://insights.sbomify.com/GHSA-mhpx-3rv8-wrjm/index.md","name":"GHSA-mhpx-3rv8-wrjm","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"patch","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP web framework","requires_auth":"unknown","summary":"Attackers can exploit insecure XML parsing in Zend Framework to read arbitrary files or cause denial of service via entity expansion.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Numerous components utilizing PHP's `DOMDocument`, `SimpleXML`, and `xml_parse` functionality are vulnerable to two types of attacks:\n\n- XML eXternal Entity (XXE) Injection attacks. The above mentioned extensions are insecure by default, allowing external entities to be specified by adding a specific DOCTYPE element to XML documents and strings. By exploiting this vulnerability an application may be coerced to open arbitrary files and/or TCP connections.\n- XML Entity Expansion (XEE) vectors, leading to Denial of Service vectors. XEE attacks occur when the XML DOCTYPE declaration includes XML entity definitions that contain either recursive or circular references; this leads to CPU and memory consumption, making Denial of Service exploits trivial to implement.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"ZendFramework potential XML eXternal Entity injection vectors","id":"GHSA-mhpx-3rv8-wrjm","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xxe","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.12.4"],"introduced":["1.12.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":null,"source":"GHSA-mhpx-3rv8-wrjm"},{"ecosystem":"Packagist","fixed":["1.12.4"],"introduced":["1.12.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":"pkg:composer/zendframework/zendframework1","source":"GHSA-mhpx-3rv8-wrjm"}],"products":null,"published":"2024-06-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can exploit insecure XML parsing in Zend Framework to read arbitrary files or cause denial of service via entity expansion.","url":"https://insights.sbomify.com/GHSA-mhpx-3rv8-wrjm/"}