{"answers":{"affected":"2 open source packages ship an affected version, including activejob.","exploited":"There is no known exploitation of GHSA-mpwp-4h2m-765c in the wild and no public exploit code.","fix":"Upgrade activejob to 4.2.0.beta2 or later.","what":"GHSA-mpwp-4h2m-765c is an unsafe deserialization vulnerability in activejob, published on 16 Jan 2026."},"fix_prompt":"Check this codebase for GHSA-mpwp-4h2m-765c and fix it if it is affected.\n\nWhat it is: GHSA-mpwp-4h2m-765c is an unsafe deserialization vulnerability in activejob, published on 16 Jan 2026. \nExploitation: There is no known exploitation of GHSA-mpwp-4h2m-765c in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- activejob (RubyGems): affected all versions; fixed in 4.2.0.beta2\n- activejob (RubyGems): affected all versions; fixed in 4.2.0.beta2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-mpwp-4h2m-765c/ (Markdown: https://insights.sbomify.com/GHSA-mpwp-4h2m-765c/index.md)","id":"GHSA-mpwp-4h2m-765c","markdown":"https://insights.sbomify.com/GHSA-mpwp-4h2m-765c/index.md","name":"GHSA-mpwp-4h2m-765c","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"unknown","non_default_config":false,"product_category":"Ruby Active Job","requires_auth":"unknown","summary":"An object injection vulnerability in Active Job allows attackers to execute arbitrary code by manipulating serialized job arguments.","user_interaction":"unknown","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Active Job vulnerability: An Active Job bug allowed String arguments to be deserialized as if they were Global IDs, an object injection security vulnerability.","ecosystems":["RubyGems"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Active Job - Object injection security vulnerability","id":"GHSA-mpwp-4h2m-765c","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"RubyGems","fixed":["4.2.0.beta2"],"introduced":["0"],"last_affected":[],"package":"activejob","purl":null,"source":"GHSA-mpwp-4h2m-765c"},{"ecosystem":"RubyGems","fixed":["4.2.0.beta2"],"introduced":["0"],"last_affected":[],"package":"activejob","purl":"pkg:gem/activejob","source":"GHSA-mpwp-4h2m-765c"}],"products":null,"published":"2026-01-16","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An object injection vulnerability in Active Job allows attackers to execute arbitrary code by manipulating serialized job arguments.","url":"https://insights.sbomify.com/GHSA-mpwp-4h2m-765c/"}