{"answers":{"affected":"2 open source packages ship an affected version, including silverstripe/framework.","exploited":"There is no known exploitation of GHSA-mqf3-qpc3-g26q in the wild and no public exploit code.","fix":"Upgrade silverstripe/framework to 5.3.8 or later.","what":"GHSA-mqf3-qpc3-g26q is a cross-site scripting vulnerability in silverstripe/framework, published on 14 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-mqf3-qpc3-g26q and fix it if it is affected.\n\nWhat it is: GHSA-mqf3-qpc3-g26q is a cross-site scripting vulnerability in silverstripe/framework, published on 14 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-mqf3-qpc3-g26q in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- silverstripe/framework (Packagist): affected all versions; fixed in 5.3.8\n- silverstripe/framework (Packagist): affected all versions; fixed in 5.3.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-mqf3-qpc3-g26q/ (Markdown: https://insights.sbomify.com/GHSA-mqf3-qpc3-g26q/index.md)","id":"GHSA-mqf3-qpc3-g26q","markdown":"https://insights.sbomify.com/GHSA-mqf3-qpc3-g26q/index.md","name":"GHSA-mqf3-qpc3-g26q","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"configuration_change","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Silverstripe Framework","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via reflected XSS in error messages when Silverstripe is misconfigured in dev mode.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"\u003e [!IMPORTANT]\n\u003e This vulnerability only affects sites which are in the \"dev\" environment mode. If your production website is in \"dev\" mode, it has been misconfigured, and you should immediately swap it to \"live\" mode.\n\u003e See https://docs.silverstripe.org/en/developer_guides/debugging/environment_types/ for more information.\n\nIf a website has been set to the \"dev\" environment mode, a URL can be provided which includes an XSS payload which will be executed in the resulting error message.\n\n## References\n\n- https://www.silverstripe.org/download/security-releases/ss-2024-002\n\n## Reported by\n\nGaurav Nayak from [Chaleit](https://chaleit.com/)","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Silverstripe Framework has a Reflected Cross Site Scripting (XSS) in error message","id":"GHSA-mqf3-qpc3-g26q","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["5.3.8"],"introduced":["0"],"last_affected":[],"package":"silverstripe/framework","purl":null,"source":"GHSA-mqf3-qpc3-g26q"},{"ecosystem":"Packagist","fixed":["5.3.8"],"introduced":["0"],"last_affected":[],"package":"silverstripe/framework","purl":"pkg:composer/silverstripe/framework","source":"GHSA-mqf3-qpc3-g26q"}],"products":null,"published":"2025-01-14","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary scripts via reflected XSS in error messages when Silverstripe is misconfigured in dev mode.","url":"https://insights.sbomify.com/GHSA-mqf3-qpc3-g26q/"}