{"answers":{"affected":"2 open source packages ship an affected version, including silverstripe/framework.","exploited":"There is no known exploitation of GHSA-mqf5-275h-gf6r in the wild and no public exploit code.","fix":"Upgrade silverstripe/framework to 3.1.14 or later.","what":"GHSA-mqf5-275h-gf6r is a cross-site scripting vulnerability in silverstripe/framework, published on 23 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-mqf5-275h-gf6r and fix it if it is affected.\n\nWhat it is: GHSA-mqf5-275h-gf6r is a cross-site scripting vulnerability in silverstripe/framework, published on 23 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-mqf5-275h-gf6r in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- silverstripe/framework (Packagist): affected from 3.1.0; fixed in 3.1.14\n- silverstripe/framework (Packagist): affected from 3.1.0; fixed in 3.1.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-mqf5-275h-gf6r/ (Markdown: https://insights.sbomify.com/GHSA-mqf5-275h-gf6r/index.md)","id":"GHSA-mqf5-275h-gf6r","markdown":"https://insights.sbomify.com/GHSA-mqf5-275h-gf6r/index.md","name":"GHSA-mqf5-275h-gf6r","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Silverstripe CMS","requires_auth":"none","summary":"An attacker can inject malicious scripts via unescaped parameters in the Silverstripe installation form, potentially compromising the site.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"During installation, certain parameters (admin_username and admin_password) are not escaped in the setup form.\n\nThis issue is resolved in 3.1.14 stable, although existing users are advised to remove this file prior to deploying to a production server.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Silverstripe framework is vulnerable to XSS in install.php","id":"GHSA-mqf5-275h-gf6r","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["3.1.14"],"introduced":["3.1.0"],"last_affected":[],"package":"silverstripe/framework","purl":null,"source":"GHSA-mqf5-275h-gf6r"},{"ecosystem":"Packagist","fixed":["3.1.14"],"introduced":["3.1.0"],"last_affected":[],"package":"silverstripe/framework","purl":"pkg:composer/silverstripe/framework","source":"GHSA-mqf5-275h-gf6r"}],"products":null,"published":"2024-05-23","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can inject malicious scripts via unescaped parameters in the Silverstripe installation form, potentially compromising the site.","url":"https://insights.sbomify.com/GHSA-mqf5-275h-gf6r/"}