# GHSA-mqq7-wxx5-mp8h: ps_checkout allows unauthorized method invocation through unvalidated parameter

> An unvalidated parameter in the PrestaShop checkout plugin allows unauthorized method invocation, potentially bypassing security controls.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not stated
- **Fix available:** Yes
- **Published:** 30 Apr 2026

## What is GHSA-mqq7-wxx5-mp8h?

GHSA-mqq7-wxx5-mp8h is a missing authorization vulnerability in prestashop/ps_checkout, published on 30 Apr 2026. It can be exploited over the network.

### Official description

### Impact

Unvalidated parameter can lead to some unauthorized method invocation with very little possibilities.

### Patches

The problem has been patched in versions

- v5.3.0 for PrestaShop 1.7 (build number: 7.5.3.0)
- v5.3.0 for PrestaShop 8 (build number: 8.5.3.0)
- v5.3.0 for PrestaShop 9 (build number: 9.5.3.0)

Read the [Versioning policy](https://github.com/PrestaShopCorp/ps_checkout/wiki/Versioning) to learn more about the build numbers.

### Credits

PrestaShop thanks [PATICEO](https://www.paticeo.com/) for reporting the issue.

## Which versions are affected by GHSA-mqq7-wxx5-mp8h?

2 open source packages ship an affected version, including prestashop/ps_checkout.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/ps_checkout` | Packagist | All versions | 5.3.0 |
| `prestashop/ps_checkout` | Packagist | All versions | 5.3.0 |

## How do I fix GHSA-mqq7-wxx5-mp8h?

Upgrade prestashop/ps_checkout to 5.3.0 or later.

## Is GHSA-mqq7-wxx5-mp8h being exploited?

There is no known exploitation of GHSA-mqq7-wxx5-mp8h in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-mqq7-wxx5-mp8h and fix it if it is affected.

What it is: GHSA-mqq7-wxx5-mp8h is a missing authorization vulnerability in prestashop/ps_checkout, published on 30 Apr 2026. It can be exploited over the network.
Exploitation: There is no known exploitation of GHSA-mqq7-wxx5-mp8h in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/ps_checkout (Packagist): affected all versions; fixed in 5.3.0
- prestashop/ps_checkout (Packagist): affected all versions; fixed in 5.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-mqq7-wxx5-mp8h/ (Markdown: https://insights.sbomify.com/GHSA-mqq7-wxx5-mp8h/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-mqq7-wxx5-mp8h

---
From sbomify Insights: https://insights.sbomify.com/GHSA-mqq7-wxx5-mp8h/
Summaries are generated and may contain mistakes; the official description above is the record.
