{"answers":{"affected":"2 open source packages ship an affected version, including ckb.","exploited":"There is no known exploitation of GHSA-p2gm-ffr3-w2xw in the wild and no public exploit code.","fix":"Upgrade ckb to 0.101.4 or later.","what":"GHSA-p2gm-ffr3-w2xw is a denial of service vulnerability in ckb, published on 8 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-p2gm-ffr3-w2xw and fix it if it is affected.\n\nWhat it is: GHSA-p2gm-ffr3-w2xw is a denial of service vulnerability in ckb, published on 8 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-p2gm-ffr3-w2xw in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ckb (crates.io): affected all versions; fixed in 0.101.4\n- ckb (crates.io): affected all versions; fixed in 0.101.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-p2gm-ffr3-w2xw/ (Markdown: https://insights.sbomify.com/GHSA-p2gm-ffr3-w2xw/index.md)","id":"GHSA-p2gm-ffr3-w2xw","markdown":"https://insights.sbomify.com/GHSA-p2gm-ffr3-w2xw/index.md","name":"GHSA-p2gm-ffr3-w2xw","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"configuration_change","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Nervos CKB node","requires_auth":"none","summary":"Attackers can cause denial of service in Nervos CKB nodes by sending low-resource flood network messages, requiring configuration changes to mitigate.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Workarounds\n* forbid request genesis through network request\n* forbid requesting duplicate data  through network request","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Nervos CKB vulnerable to low-resource flood DDoS attacks through network message","id":"GHSA-p2gm-ffr3-w2xw","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.101.4"],"introduced":["0"],"last_affected":[],"package":"ckb","purl":null,"source":"GHSA-p2gm-ffr3-w2xw"},{"ecosystem":"crates.io","fixed":["0.101.4"],"introduced":["0"],"last_affected":[],"package":"ckb","purl":"pkg:cargo/ckb","source":"GHSA-p2gm-ffr3-w2xw"}],"products":null,"published":"2023-02-08","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service in Nervos CKB nodes by sending low-resource flood network messages, requiring configuration changes to mitigate.","url":"https://insights.sbomify.com/GHSA-p2gm-ffr3-w2xw/"}