GHSA-p68v-frgx-4rjp Denial of Service via Cache Flooding
Attackers can cause denial of service by flooding the cache, affecting Shopware e-commerce platforms.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-p68v-frgx-4rjp?
GHSA-p68v-frgx-4rjp is a denial of service vulnerability in shopware/core, published on 19 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Impact
Denial of Service via Cache Flooding
Patches
We recommend to update to the current version 6.3.2.1. You can get the update to 6.3.2.1 regularly via the Auto-Updater or directly via the download overview.
https://www.shopware.com/en/download/#shopware-6
Workarounds
For older versions of 6.1 and 6.2 the corresponding changes are also available via plugin:
https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659
For more information
https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-10-2020
Which versions are affected by GHSA-p68v-frgx-4rjp?
4 open source packages ship an affected version, including shopware/core and shopware/platform.
| Package | Affected | Fixed in |
|---|---|---|
shopware/core Packagist | All versions | 6.3.2.1 |
shopware/core Packagist | All versions | 6.3.2.1 |
shopware/platform Packagist | All versions | 6.3.2.1 |
shopware/platform Packagist | All versions | 6.3.2.1 |
How do I fix GHSA-p68v-frgx-4rjp?
Upgrade shopware/core to 6.3.2.1 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is GHSA-p68v-frgx-4rjp being exploited?
There is no known exploitation of GHSA-p68v-frgx-4rjp in the wild and no public exploit code.