{"answers":{"affected":"20 open source packages ship an affected version, including cakephp/cakephp.","exploited":"There is no known exploitation of GHSA-p76f-wr22-4rv6 in the wild and no public exploit code.","fix":"Upgrade cakephp/cakephp to a fixed version for your release line: 2.0.99, 2.1.99, 2.2.99 or 2.3.99.","what":"GHSA-p76f-wr22-4rv6 is a path traversal vulnerability in cakephp/cakephp, published on 20 Jan 2023. It can be exploited over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-p76f-wr22-4rv6 and fix it if it is affected.\n\nWhat it is: GHSA-p76f-wr22-4rv6 is a path traversal vulnerability in cakephp/cakephp, published on 20 Jan 2023. It can be exploited over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-p76f-wr22-4rv6 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cakephp/cakephp (Packagist): affected from 2.0.0; fixed in 2.0.99\n- cakephp/cakephp (Packagist): affected from 2.0.0; fixed in 2.0.99\n- cakephp/cakephp (Packagist): affected from 2.1.0; fixed in 2.1.99\n- cakephp/cakephp (Packagist): affected from 2.1.0; fixed in 2.1.99\n- cakephp/cakephp (Packagist): affected from 2.2.0; fixed in 2.2.99\n- cakephp/cakephp (Packagist): affected from 2.2.0; fixed in 2.2.99\n- cakephp/cakephp (Packagist): affected from 2.3.0; fixed in 2.3.99\n- cakephp/cakephp (Packagist): affected from 2.3.0; fixed in 2.3.99\n- cakephp/cakephp (Packagist): affected from 2.4.0; fixed in 2.4.99\n- cakephp/cakephp (Packagist): affected from 2.4.0; fixed in 2.4.99\n- cakephp/cakephp (Packagist): affected from 2.5.0; fixed in 2.5.99\n- cakephp/cakephp (Packagist): affected from 2.5.0; fixed in 2.5.99\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-p76f-wr22-4rv6/ (Markdown: https://insights.sbomify.com/GHSA-p76f-wr22-4rv6/index.md)","id":"GHSA-p76f-wr22-4rv6","markdown":"https://insights.sbomify.com/GHSA-p76f-wr22-4rv6/index.md","name":"GHSA-p76f-wr22-4rv6","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"CakePHP framework","requires_auth":"unknown","summary":"Attackers can execute arbitrary code or read sensitive files by manipulating view template names in CakePHP applications.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"CakePHP 2.x prior to 2.0.99, 2.1.99, 2.2.99, 2.3.99, 2.4.99, 2.5.99, 2.6.12, and 2.7.6 and 3.x prior to 3.0.15 and 3.1.4 is vulnerable to Remote File Inclusion through View template name manipulation.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"CakePHP vulnerable to Remote File Inclusion through View template name manipulation","id":"GHSA-p76f-wr22-4rv6","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2023"},"n_packages":20,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.0.99"],"introduced":["2.0.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["2.0.99"],"introduced":["2.0.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["2.1.99"],"introduced":["2.1.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["2.1.99"],"introduced":["2.1.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["2.2.99"],"introduced":["2.2.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["2.2.99"],"introduced":["2.2.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["2.3.99"],"introduced":["2.3.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["2.3.99"],"introduced":["2.3.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["2.4.99"],"introduced":["2.4.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["2.4.99"],"introduced":["2.4.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["2.5.99"],"introduced":["2.5.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["2.5.99"],"introduced":["2.5.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["2.6.12"],"introduced":["2.6.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["2.6.12"],"introduced":["2.6.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["2.7.6"],"introduced":["2.7.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["2.7.6"],"introduced":["2.7.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["3.0.15"],"introduced":["3.0.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["3.0.15"],"introduced":["3.0.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["3.1.4"],"introduced":["3.1.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-p76f-wr22-4rv6"},{"ecosystem":"Packagist","fixed":["3.1.4"],"introduced":["3.1.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-p76f-wr22-4rv6"}],"products":null,"published":"2023-01-20","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary code or read sensitive files by manipulating view template names in CakePHP applications.","url":"https://insights.sbomify.com/GHSA-p76f-wr22-4rv6/"}