# GHSA-p76f-wr22-4rv6: CakePHP vulnerable to Remote File Inclusion through View template name manipulation

> Attackers can execute arbitrary code or read sensitive files by manipulating view template names in CakePHP applications.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jan 2023

## What is GHSA-p76f-wr22-4rv6?

GHSA-p76f-wr22-4rv6 is a path traversal vulnerability in cakephp/cakephp, published on 20 Jan 2023. It can be exploited over the network, with no action from the victim.

### Official description

CakePHP 2.x prior to 2.0.99, 2.1.99, 2.2.99, 2.3.99, 2.4.99, 2.5.99, 2.6.12, and 2.7.6 and 3.x prior to 3.0.15 and 3.1.4 is vulnerable to Remote File Inclusion through View template name manipulation.

## Which versions are affected by GHSA-p76f-wr22-4rv6?

20 open source packages ship an affected version, including cakephp/cakephp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cakephp/cakephp` | Packagist | From 2.0.0 | 2.0.99 |
| `cakephp/cakephp` | Packagist | From 2.0.0 | 2.0.99 |
| `cakephp/cakephp` | Packagist | From 2.1.0 | 2.1.99 |
| `cakephp/cakephp` | Packagist | From 2.1.0 | 2.1.99 |
| `cakephp/cakephp` | Packagist | From 2.2.0 | 2.2.99 |
| `cakephp/cakephp` | Packagist | From 2.2.0 | 2.2.99 |
| `cakephp/cakephp` | Packagist | From 2.3.0 | 2.3.99 |
| `cakephp/cakephp` | Packagist | From 2.3.0 | 2.3.99 |
| `cakephp/cakephp` | Packagist | From 2.4.0 | 2.4.99 |
| `cakephp/cakephp` | Packagist | From 2.4.0 | 2.4.99 |
| `cakephp/cakephp` | Packagist | From 2.5.0 | 2.5.99 |
| `cakephp/cakephp` | Packagist | From 2.5.0 | 2.5.99 |
| `cakephp/cakephp` | Packagist | From 2.6.0 | 2.6.12 |
| `cakephp/cakephp` | Packagist | From 2.6.0 | 2.6.12 |
| `cakephp/cakephp` | Packagist | From 2.7.0 | 2.7.6 |
| `cakephp/cakephp` | Packagist | From 2.7.0 | 2.7.6 |
| `cakephp/cakephp` | Packagist | From 3.0.0 | 3.0.15 |
| `cakephp/cakephp` | Packagist | From 3.0.0 | 3.0.15 |
| `cakephp/cakephp` | Packagist | From 3.1.0 | 3.1.4 |
| `cakephp/cakephp` | Packagist | From 3.1.0 | 3.1.4 |

## How do I fix GHSA-p76f-wr22-4rv6?

Upgrade cakephp/cakephp to a fixed version for your release line: 2.0.99, 2.1.99, 2.2.99 or 2.3.99.

## Is GHSA-p76f-wr22-4rv6 being exploited?

There is no known exploitation of GHSA-p76f-wr22-4rv6 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-p76f-wr22-4rv6 and fix it if it is affected.

What it is: GHSA-p76f-wr22-4rv6 is a path traversal vulnerability in cakephp/cakephp, published on 20 Jan 2023. It can be exploited over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-p76f-wr22-4rv6 in the wild and no public exploit code.

Affected packages and fixed versions:
- cakephp/cakephp (Packagist): affected from 2.0.0; fixed in 2.0.99
- cakephp/cakephp (Packagist): affected from 2.0.0; fixed in 2.0.99
- cakephp/cakephp (Packagist): affected from 2.1.0; fixed in 2.1.99
- cakephp/cakephp (Packagist): affected from 2.1.0; fixed in 2.1.99
- cakephp/cakephp (Packagist): affected from 2.2.0; fixed in 2.2.99
- cakephp/cakephp (Packagist): affected from 2.2.0; fixed in 2.2.99
- cakephp/cakephp (Packagist): affected from 2.3.0; fixed in 2.3.99
- cakephp/cakephp (Packagist): affected from 2.3.0; fixed in 2.3.99
- cakephp/cakephp (Packagist): affected from 2.4.0; fixed in 2.4.99
- cakephp/cakephp (Packagist): affected from 2.4.0; fixed in 2.4.99
- cakephp/cakephp (Packagist): affected from 2.5.0; fixed in 2.5.99
- cakephp/cakephp (Packagist): affected from 2.5.0; fixed in 2.5.99

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-p76f-wr22-4rv6/ (Markdown: https://insights.sbomify.com/GHSA-p76f-wr22-4rv6/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-p76f-wr22-4rv6

---
From sbomify Insights: https://insights.sbomify.com/GHSA-p76f-wr22-4rv6/
Summaries are generated and may contain mistakes; the official description above is the record.
