{"answers":{"affected":"2 open source packages ship an affected version, including vp-toolkit.","exploited":"There is no known exploitation of GHSA-p94w-42g3-f7h4 in the wild and no public exploit code.","fix":"Upgrade vp-toolkit to 0.2.2 or later.","what":"GHSA-p94w-42g3-f7h4 is a vulnerability in vp-toolkit, published on 6 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-p94w-42g3-f7h4 and fix it if it is affected.\n\nWhat it is: GHSA-p94w-42g3-f7h4 is a vulnerability in vp-toolkit, published on 6 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-p94w-42g3-f7h4 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vp-toolkit (npm): affected all versions; fixed in 0.2.2\n- vp-toolkit (npm): affected all versions; fixed in 0.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-p94w-42g3-f7h4/ (Markdown: https://insights.sbomify.com/GHSA-p94w-42g3-f7h4/index.md)","id":"GHSA-p94w-42g3-f7h4","markdown":"https://insights.sbomify.com/GHSA-p94w-42g3-f7h4/index.md","name":"GHSA-p94w-42g3-f7h4","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Verifiable Credential library","requires_auth":"none","summary":"A verifier can be tricked into accepting forged credentials because the library fails to validate that the credential issuer matches the cryptographic signer.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nThe [`verifyVerifiableCredential()`](https://github.com/rabobank-blockchain/vp-toolkit/blob/master/src/service/signers/verifiable-credential-signer.ts#L57) method check the cryptographic integrity of the Verifiable Credential, but it does not check if the [`credential.issuer`](https://github.com/rabobank-blockchain/vp-toolkit-models/blob/develop/src/model/verifiable-credential.ts#L129) DID matches the signer of the credential.\n\nThe **verifier** is impacted by this vulnerability.\n\n### Patches\nPatch will be available in version 0.2.2.\n\n### Workarounds\nIn case you trust certain issuers for certain credentials as a verifier, trust the issuer\u0026#39;s public key from the `credential.proof.verificationMethod` field.\n\n### References\n[Github issue](https://github.com/rabobank-blockchain/vp-toolkit/issues/13)\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Discuss in the existing [issue](https://github.com/rabobank-blockchain/vp-toolkit/issues/13)\n* [Contact me](https://github.com/rabomarnix)","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Holder can (re)create authentic credentials after receiving a credential in vp-toolkit","id":"GHSA-p94w-42g3-f7h4","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.2.2"],"introduced":["0"],"last_affected":[],"package":"vp-toolkit","purl":null,"source":"GHSA-p94w-42g3-f7h4"},{"ecosystem":"npm","fixed":["0.2.2"],"introduced":["0"],"last_affected":[],"package":"vp-toolkit","purl":"pkg:npm/vp-toolkit","source":"GHSA-p94w-42g3-f7h4"}],"products":null,"published":"2020-03-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A verifier can be tricked into accepting forged credentials because the library fails to validate that the credential issuer matches the cryptographic signer.","url":"https://insights.sbomify.com/GHSA-p94w-42g3-f7h4/"}