{"answers":{"affected":"2 open source packages ship an affected version, including https-proxy-agent.","exploited":"There is no known exploitation of GHSA-pc5p-h8pf-mvwp in the wild and no public exploit code.","fix":"Upgrade https-proxy-agent to 2.2.3 or later.","what":"GHSA-pc5p-h8pf-mvwp is a vulnerability in https-proxy-agent, published on 16 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-pc5p-h8pf-mvwp and fix it if it is affected.\n\nWhat it is: GHSA-pc5p-h8pf-mvwp is a vulnerability in https-proxy-agent, published on 16 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-pc5p-h8pf-mvwp in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- https-proxy-agent (npm): affected all versions; fixed in 2.2.3\n- https-proxy-agent (npm): affected all versions; fixed in 2.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-pc5p-h8pf-mvwp/ (Markdown: https://insights.sbomify.com/GHSA-pc5p-h8pf-mvwp/index.md)","id":"GHSA-pc5p-h8pf-mvwp","markdown":"https://insights.sbomify.com/GHSA-pc5p-h8pf-mvwp/index.md","name":"GHSA-pc5p-h8pf-mvwp","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js proxy library","requires_auth":"none","summary":"Attackers can intercept unencrypted traffic via MITM if the proxy returns non-200 status, exposing sensitive data like credentials.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `https-proxy-agent` prior to 2.2.3 are vulnerable to Machine-In-The-Middle. The package fails to enforce TLS on the socket if the proxy server responds the to the request with a HTTP status different than 200. This allows an attacker with access to the proxy server to intercept unencrypted communications, which may include sensitive information such as credentials.\n\n## Recommendation\n\nUpgrade to version 3.0.0 or 2.2.3.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Machine-In-The-Middle in https-proxy-agent","id":"GHSA-pc5p-h8pf-mvwp","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.2.3"],"introduced":["0"],"last_affected":[],"package":"https-proxy-agent","purl":null,"source":"GHSA-pc5p-h8pf-mvwp"},{"ecosystem":"npm","fixed":["2.2.3"],"introduced":["0"],"last_affected":[],"package":"https-proxy-agent","purl":"pkg:npm/https-proxy-agent","source":"GHSA-pc5p-h8pf-mvwp"}],"products":null,"published":"2020-04-16","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can intercept unencrypted traffic via MITM if the proxy returns non-200 status, exposing sensitive data like credentials.","url":"https://insights.sbomify.com/GHSA-pc5p-h8pf-mvwp/"}