# GHSA-pc9j-5v36-2mww: AWS SDK for Swift adopted defense in depth enhancement for region parameter value

> An attacker with environment access could manipulate region parameters to route AWS API calls to non-AWS hosts, mitigated by input validation in the SDK.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2026

## What is GHSA-pc9j-5v36-2mww?

GHSA-pc9j-5v36-2mww is a server-side request forgery vulnerability in github.com/awslabs/aws-sdk-swift, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CVSSv3.1 Rating: 3.7 (LOW)

Summary
This notification is related to the use of specific values for the region input field when calling AWS services. An actor with access to the environment in which the SDK is used could set the region input field to an invalid value.

A defense-in-depth enhancement has been implemented in the AWS SDK for Swift. This enhancement validates that a region used to construct an endpoint URL is a valid host label. The change was released on November 6, 2025. This advisory is informational to help customers understand their responsibilities regarding configuration security.

Impact
Customer applications could be configured to improperly route AWS API calls to non-existent or non-AWS hosts. While the SDK was functioning safely within the requirements of the shared responsibility model, additional safeguards have been added to support secure customer implementations.

Impacted versions: All versions prior to 2025-11-06 release (below 1.5.79) 

Patches
On November 6, 2025 an enhancement was made to the AWS SDK for Swift release, which validates the formatting of a region, providing additional safeguards.

Workarounds
No workarounds are needed, but as always you should ensure that your application is following security best practices:
- Implement proper input validation in your application code
- Update to the latest AWS SDK for Swift release on a regular basis
- Follow AWS security best practices [1] for SDK configuration

References
Contact AWS Security via the vulnerability reporting page or email [aws-security@amazon.com](mailto:aws-security@amazon.com).

Acknowledgement
AWS SDK thanks Guy Arazi for bringing these customer security considerations to our attention through the coordinated disclosure process.

 

[1] https://docs.aws.amazon.com/sdk-for-swift/latest/developer-guide/security.html

## Which versions are affected by GHSA-pc9j-5v36-2mww?

2 open source packages ship an affected version, including github.com/awslabs/aws-sdk-swift.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/awslabs/aws-sdk-swift` | SwiftURL | All versions | 1.5.79 |
| `github.com/awslabs/aws-sdk-swift` | SwiftURL | All versions | 1.5.79 |

## How do I fix GHSA-pc9j-5v36-2mww?

Upgrade github.com/awslabs/aws-sdk-swift to 1.5.79 or later.

## Is GHSA-pc9j-5v36-2mww being exploited?

There is no known exploitation of GHSA-pc9j-5v36-2mww in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-pc9j-5v36-2mww and fix it if it is affected.

What it is: GHSA-pc9j-5v36-2mww is a server-side request forgery vulnerability in github.com/awslabs/aws-sdk-swift, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-pc9j-5v36-2mww in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/awslabs/aws-sdk-swift (SwiftURL): affected all versions; fixed in 1.5.79
- github.com/awslabs/aws-sdk-swift (SwiftURL): affected all versions; fixed in 1.5.79

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-pc9j-5v36-2mww/ (Markdown: https://insights.sbomify.com/GHSA-pc9j-5v36-2mww/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-pc9j-5v36-2mww

---
From sbomify Insights: https://insights.sbomify.com/GHSA-pc9j-5v36-2mww/
Summaries are generated and may contain mistakes; the official description above is the record.
