{"answers":{"affected":"2 open source packages ship an affected version, including user_agent_parser.","exploited":"There is no known exploitation of GHSA-pcqq-5962-hvcw in the wild and no public exploit code.","fix":"Upgrade user_agent_parser to 2.6.0 or later.","what":"GHSA-pcqq-5962-hvcw is a denial of service vulnerability in user_agent_parser, published on 10 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-pcqq-5962-hvcw and fix it if it is affected.\n\nWhat it is: GHSA-pcqq-5962-hvcw is a denial of service vulnerability in user_agent_parser, published on 10 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-pcqq-5962-hvcw in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- user_agent_parser (RubyGems): affected all versions; fixed in 2.6.0\n- user_agent_parser (RubyGems): affected all versions; fixed in 2.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-pcqq-5962-hvcw/ (Markdown: https://insights.sbomify.com/GHSA-pcqq-5962-hvcw/index.md)","id":"GHSA-pcqq-5962-hvcw","markdown":"https://insights.sbomify.com/GHSA-pcqq-5962-hvcw/index.md","name":"GHSA-pcqq-5962-hvcw","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby user-agent parser","requires_auth":"none","summary":"Remote attackers can cause denial of service in applications using uap-core by sending crafted User-Agent strings that trigger regex backtracking.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nSome regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings.\n\n### Patches\nPlease update `uap-ruby` to \u0026gt;= v2.6.0\n\n### For more information\nhttps://github.com/ua-parser/uap-core/security/advisories/GHSA-cmcx-xhr8-3w9p\n\nReported in `uap-core` by Ben Caller @bcaller","ecosystems":["RubyGems"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of Service in uap-core when processing crafted User-Agent strings","id":"GHSA-pcqq-5962-hvcw","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"RubyGems","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"user_agent_parser","purl":null,"source":"GHSA-pcqq-5962-hvcw"},{"ecosystem":"RubyGems","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"user_agent_parser","purl":"pkg:gem/user_agent_parser","source":"GHSA-pcqq-5962-hvcw"}],"products":null,"published":"2020-03-10","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Remote attackers can cause denial of service in applications using uap-core by sending crafted User-Agent strings that trigger regex backtracking.","url":"https://insights.sbomify.com/GHSA-pcqq-5962-hvcw/"}