{"answers":{"affected":"2 open source packages ship an affected version, including openclaw.","exploited":"There is no known exploitation of GHSA-pfv7-rr5m-qmv6 in the wild and no public exploit code.","fix":"Upgrade openclaw to 2026.2.19 or later.","what":"GHSA-pfv7-rr5m-qmv6 is an authentication bypass vulnerability in openclaw, published on 3 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-pfv7-rr5m-qmv6 and fix it if it is affected.\n\nWhat it is: GHSA-pfv7-rr5m-qmv6 is an authentication bypass vulnerability in openclaw, published on 3 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-pfv7-rr5m-qmv6 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openclaw (npm): affected all versions; fixed in 2026.2.19\n- openclaw (npm): affected all versions; fixed in 2026.2.19\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-pfv7-rr5m-qmv6/ (Markdown: https://insights.sbomify.com/GHSA-pfv7-rr5m-qmv6/index.md)","id":"GHSA-pfv7-rr5m-qmv6","markdown":"https://insights.sbomify.com/GHSA-pfv7-rr5m-qmv6/index.md","name":"GHSA-pfv7-rr5m-qmv6","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"OpenClaw relay server","requires_auth":"none","summary":"Local attackers can bypass authentication on the OpenClaw extension relay endpoint if the feature is enabled, interfering with relay behavior.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\n\nWhen the optional Chrome extension relay is enabled, `/extension` accepted unauthenticated WebSocket upgrades while `/json/*` and `/cdp` required auth.\n\n### Affected Packages / Versions\n\n- Package: `openclaw` (npm)\n- Affected: `\u003c= 2026.2.17`\n- Latest published npm version at triage time: `2026.2.17`\n\n### Impact\n\nThis is a local-only issue on loopback (`127.0.0.1`) and only applies when the extension relay feature is in use. A local process on the same machine could connect to `/extension` without the token and interfere with extension-relay behavior.\n\nNo remote network exploit path is involved.\n\n### Fix\n\n- Require gateway-token auth on both `/extension` and `/cdp` relay WebSocket endpoints.\n- Keep loopback/origin checks as defense-in-depth, not as authentication.\n- Use one token path in setup: `gateway.auth.token` / `OPENCLAW_GATEWAY_TOKEN`.\n\n### Fix Commit(s)\n\n- `7e54b6c96feb1a5c30884f2b32037b8dadd0e532`\n\nOpenClaw thanks @tdjackey for reporting.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"OpenClaw has auth inconsistency on local Browser Extension Relay /extension endpoint","id":"GHSA-pfv7-rr5m-qmv6","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2026.2.19"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":null,"source":"GHSA-pfv7-rr5m-qmv6"},{"ecosystem":"npm","fixed":["2026.2.19"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":"pkg:npm/openclaw","source":"GHSA-pfv7-rr5m-qmv6"}],"products":null,"published":"2026-03-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Local attackers can bypass authentication on the OpenClaw extension relay endpoint if the feature is enabled, interfering with relay behavior.","url":"https://insights.sbomify.com/GHSA-pfv7-rr5m-qmv6/"}