GHSA-pg98-6v7f-2xfv sweetalert2 v9.17.4 and above contains hidden functionality
The sweetalert2 library contains hidden audio/video functionality introduced by the maintainer, requiring an upgrade to remove this unexpected behavior.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-pg98-6v7f-2xfv?
GHSA-pg98-6v7f-2xfv is a vulnerability in sweetalert2, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
sweetalert2 versions 9.17.4 and up until 10.0.0 are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 9.0.0 - 9.17.3.
Workaround
Users who are unable to update to the fixed version (11.22.4) can use package versions 9.0.0-9.17.3, as they do not contain the hidden functionality.
Which versions are affected by GHSA-pg98-6v7f-2xfv?
2 open source packages ship an affected version, including sweetalert2.
| Package | Affected | Fixed in |
|---|---|---|
sweetalert2 npm | From 9.17.4 | 11.22.4 |
sweetalert2 npm | From 9.17.4 | 11.22.4 |
How do I fix GHSA-pg98-6v7f-2xfv?
Upgrade sweetalert2 to 11.22.4 or later.
Is GHSA-pg98-6v7f-2xfv being exploited?
There is no known exploitation of GHSA-pg98-6v7f-2xfv in the wild and no public exploit code.